No graphics device with hardware support

I am trying to launch the game and just keeps giving me this error.

“No graphics device with hardware support was found using DirectX!
If this is not correct restarting the computer might help”

I have tried restarting, graphic drivers are up to date, i have tried launching in compatibility mode.

On the launcher, there is a settings button, click that, can you choose one there?

I have 3 options
“primary display driver - RGB emulation”
“Nvidia geforce gtx 970 - RGB emulation”
“Nvidia geforce gtx 970 - RGB emulation”

I assume that the two bottom ones are my 2 montiors, but now I see that neither are directx options

Try installing directX 9

The game uses an older version than the one that comes with newer windows

I had that dx9 version installed and had to do it again recently to make AO find the graphic card.
Guess a windows 10 update was the reason.
So i installed the latest nvidia driver and dx9 again. No change. After a reboot all was ok again.
No idea why but it worked that way for me.

They should really make a sticky with the directX link, or update the client. The question comes up all the time.

1 Like

thanks, I was still unable to get it to work with that suggestion. but the engine new works fine. so i am playing again thanks!