No server listed


I bought the game 4 days ago and when i try to play in multiplayer i have 0 server listed in the in-game Multiplayer list.

I tried to connect to another wireless connexion and then all server were showed in the list.
I think my router is bloking some ports so i’ve tried to forwards some found in the internet.
But none of the ports that i’ve opened solved my problems

Here are the ports that i opened in my router:

27000-27050 both
28800-28800 both
28815-28815 both
41765-41766 UDP
7777-7780 UDP
14001-14001 UDP
50000-65535 UDP
4380-4380 UDP
27060-27060 both
25575-25575 TCP
3389-3389 TCP

However, in steam, when i go to View -> Servers, i can see all servers for Conan Exiles with active players but when i right click “View info” on any server, it shows “Server is not responding” And when i try to connect to the server by this way, it results in the same result “can’t connect to the server”

Can you please try to help me?

Thank you in advance,

Hi @shayz, welcome to the forums!

Could you please try the workarounds suggested in our technical FAQ for PC and let us know if they help?

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.