No Sound through Headphones

question

#1

Age of Conan won’t play through my headphones [Logitech G35]

First, the specs:

W10
Nvidia GTX 1070
AMD FX-6300 @ 4.3Ghz

I’ve downloaded Age of Conan through Steam AND through the Funcom Client and no matter what, I cannot get sound through my headset.

  • Launch game with Headset set as default sound device
  • No sound
  • Close game
  • Launch game with 5.1 SRS set as default [through Realtek Sound Device]
  • Sound

These headphones have no issue with any other title in my 1400+ library, nor Discord nor Youtube nor Podcasts nor any other software.

Yes, I have tried the “repair game files” button in the launcher
Yes, I have tried setting default sound settings
Yes, I have tried setting sound to “stereo”
Yes, I have tried toggling sound on and off, including relaunching between toggles [a F&*$ing ordeal with how long the launcher takes to verify files EVERY TIME IT LAUNCHES…]
Nothing has worked. The Game doesn’t even show up in my Volume Mixer when I have the headset set as default [Nor does it show up for other devices in the Volume Mixer dropdown]

Why? Why is this a thing at all?

Please help.


#2

Hi!
I experienced this too. Make sure you set sound to 5.1/7.1 or whatever your preference is and then make sure you start AoC as Administrator. These USB-headsets has some advanced driver-features that need this.

You can edit the shortcut to AoC and make sure it runs at Administratormode everytime. Just get back here if you need more instructions.

Regards / BlackT


#3

Unfortunately, it’s very hard for us to help with sound issues. There is a wide range of potential audio hardware and output devices for us to reliably be able to help. Keep in mind that sound settings can be changed in a number of places:

-The in-game audio settings, or the Options window from the main patcher window when starting the game.

-The Windows Audio/Sound settings from the Windows Control Panel

-Whatever configuration applications may have come with your audio hardware or your output hardware

Check for conflicts with these settings as this could result in no sound like you describe.


#4

I do tech support for a living and this is a terrible response. Not only am I a power user in regards to PC’s, but I explicitly detailed how my USB headset was configured, and explained that I’ve had no success of even getting the application to SHOW UP in my Volume Mixer, but there’s zero issue when a 3.5mm speaker system is enabled, and you have zero advice as to why your application is broken [as I mentioned, I’ve had no issues with 1,400 other games in my library as well as hundreds of other applications over the past 5 years…]

Guess I’ll uninstall and never play a FUNCOM title again, thanks for the lackluster response…


#5

does your headset show up as a sound device ? is it set as default device ?


#6

Please read the post before you comment.

" * Launch game with Headset set as default sound device

  • No sound
  • Close game
  • Launch game with 5.1 SRS set as default [through Realtek Sound Device]
  • Sound"

#7

Bye Felicia :joy_cat::joy_cat::joy_cat:


#8

its new headphones? mb problem in driver, did u checked it?


#9

If the application is missing from the volume mixer it might be because of your OS.

Start -> Control Panel -> Sound -> Double click on speakers -> Advanced tab -> check “Allow applications to take exclusive control of this device”

Once you click ok you have to restart the game.