Not getting Boss heads

Game mode: [Online]
Problem: [Bug]
Region: [EUPS4]

So I’ve been trying to finish the journey quest for getting the head of a boss creature. So far I’ve killed three bosses for this specific purpose (Pretty sure I’ve killed other bosses and just didn’t notice). The bosses I’ve killed are, the shaleback king way west of the map, just north of the friendly city where you can find conan, the huge crocodile in the Brimstone cave and I stubled upon what looked like a boss version of those stone creatures you find near metal nodes. All of these bosses gave me a ps4 trophy, but none of them dropped heads. I tried harvesting them with my pick and a skinning kinfe as far I can remember.

No heads, no journey completed. Are the bosses I’ve been killing not strong enough or what?

Steps on how to reproduce issue:

  1. Kill boss
  2. Not getting head from boss

I might be wrong but do heads not have to be harvested with a hatchet (axe) rather than a pick axe.

1 Like

I will definitely test this later today. I’m pretty sure I harvested atleast one of these guys with my pickaxe, the pick and axe combo.

I’ve read that there is a 50% drop chance on the skeleton keys, so this might be the case with heads aswell.

I tried the shaleback a few days ago with the axe and I got the head. Pretty sure I never got any key though.

1 Like

Aye, use an axe. I use the cleaver but the axe can work too.

1 Like

Use a cleaver, and make sure you are positioned at the head.

Use at least iron axe and try moose king or whatever the name is he has the best drop rate.
It’s rather low drop did scorpion and croc 20-30 times no dice, moose 3 for 9 ,locust 1 from 15 tries

The pickaxe has issues collecting because it’s both an axe and pickaxe. Try a dedicated tool.

Using a cleaver seems to work the best from my experience, but there’s still a small chance of getting them. I can’t seem to get an ape head but ive gotten a few others