Official server #1064 - Failed to place building


#1

Hi, i want to report a bug.

Today I logged in and tried to build some stuff in my house, but I could not. I can’t build anything in some blocks around my house.

When I try to put for example a chest I don’t get any feedback but when I try to put a block like a wall i get the “Failed to place building” message. I also noticed checking the event list that something called “Verfallssystem” destroyed my trebuchet. I don’t know why and I neither know if that bugged my house.

The coordinates of my house are: -67038.585938 135270.46875 -8869.521484


#2

Stability?


#3

verfail is a stability issue, so that’s why your trebuchet disappeared.

The failing to place building is something I’ve fixed in the past by logging off and then back on the server.


#4

I’m Doberick’s mate.
We don’t know how to check stability, but that would explain why the trbuchet disappeared.
Anyways, that was not the most important problem. That problem is that we cannot build in a certain place of our base anymore (the most important place, btw).
We logged off and in many times, and it didn’t work. It happens to both of us, so it cannot be a player-related problem.

We don’t know how to keep on building in our base -.-

Thanks for your answers anyways guys.


#5

Use your hammer to check for stability.

Edit: this comment is wrong : Verafall is decay timer not instability


#6

But that still wouldn’t explain why we cannot build in a certain zone of our base, right?
Or would it?


#7

I don’t know where those coordinates are. It may be that it is near a blocked area and the placables are in a spot of the build that is ok.

When you are trying to place it is there any work benches under over or near it. the collision box is wonky sometimes


#8

The thing is that we have been building there for days without a problem. In fact, we discovered the problem when Doberick destroyed a fire in order to place a bigger one, and he couldn’t build in that same place. He tried to build next to that place, and it was also bugged.

So, there’s not thrall camps or any other thing, we have been working there the previous days without any problem.

In fact, the “ghost” of the constructions appears in yellow, which would imply we can build there. But, when we click, “failed to place the building” message appears.


#9

Do you have any furnaces or crafting stations near it. even on the floor above or below?


#10

Liked your post for the first part.

Second is wrong.

Decay timer removal is listed as ruin system in log.


#11

My bad then


#12

Yes. In fact, in that floor we have all of our crafting stations.
And, in the first floor, the furnace.

Could that be the problem? And why just popped in out of nowhere? If a crafting stations would have been the problem, it would have let us build there since we placed it, right?


#13

Ahhh, yes, that’s likely it.

I’ve noticed that if I place a first floor and then crafting stations on it and then attempt to do a second floor, it won’t let me put a ceiling right above a furnace - example. But if I were to build the ceiling tile and then place the furnace on the first floor, everything would be fine.

So if you were to destroy your furnace, you should be able to place a ceiling above it and then you can replace your furnace. Not an optimal fix or something that should be a thing, but a fix nonetheless.


#14

For example you can place a furnace on a one story floor that has a roof tile directly above it. If you remove that ceiling tile it cannot be replaced until the furnace is removed. I found this out the hard way lol


#15

But that furnace was built there days ago.

We placed the furnace. We build around it. We build a second floor over the furnace. We build floors, ceilings, walls, everything. We placed in that floor every other crafting station. Everything worked fine.

Now, out of nowhere, we cannot build in that zone. Not onlu over the furnace, but like 4 o 5 blocks of distance from that zone.

Is that normal? Can that be possible?

Would you reccommend me to take off the furnace anyway to try?


#16

furnaces are cheap its worth a try, but be aware of its a glitch of some sort, maybe you cannot put a new one back


#17

I will try and let you know as soon as I’m able. Thanks for the answers guys!


#18

When I had this issue, it was only the ceiling tile directly above the furnace that caused the problem. I’ve only noticed that furnaces and fireplaces cause this issue to occur.

Why it’s prohibiting you from building 4-5 blocks a way is baffling to me.

And the fact you were allowed to build over it originally also baffles me.


#19

Yeah, I don’t know. And it all happened all of a sudden. Maybe it has something to do with the server restart or something like that, but if taking off the furnace doesn’t work I think we will have to build another base in another place.

Thank God it was only Tier 1 buildings :joy:


#20

Well a tier 1 base being wrecked ain’t no big thing, you can gather up the materials to make a new T1 base quickly.

Still hope removing the furnace for you works.