Official Server 1974 Performance

Game mode: Online official
Type of issue: Performance
Server type: PvP
Region: Oceania


Official Server 1974 experiences significant performance issues, including teleporting during combat with both other players and NPCs. Sometimes, inability to mine nodes, including iron, rock or trees. Doors experience extreme lag when opening.

Running on ADSL 2, have 8 MBps connection.
No background apps, all other game launchers, browsers, chrome etc closed and this issue persists.
It can be alleviated by bridging internet from a 4G phone where the bandwidth increases to approximately 14 Mbps but these issues only become slightly less noticable.

I have eliminated Qos and even implemented port forwarding on the following ports which has not remedied the situation.

  • TCP: 3074.
  • UDP: 88,500,3074,3544,4500.

Can supply links to six videos demonstrating the phenomenon, some with Unigraph enabled but would rather direct message them to a support member.

EDIT: have a screenshot of ping results showing average latency 19ms and NO packet loss for 200 packets to same server.

P.S. Issue is experienced by a friend with significantly higher bandwidth connection, operating at 45 Mbps.

Computer specs:
CPU: Intel Core i7 4770K 3.5GHz
Mobo: AsRock z87 OC Formula
RAM: 32GB
GPU: Nvidia GTX 1080 Ti
SSD: Samsung 850 Evo 1Tb


Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Combat with NPCs or players
  2. Opening doors
  3. Farming nodes
1 Like

Hey there @Dingo

Welcome to our community. :slight_smile:
To report official server performance issues or inform of any server outage please use the Server report tool or contact G-Portal through their usual communication channels.
Thanks.

1 Like

Thanks! Done.

On the other hand, we will soon deploy a new set of tech optimizations in our live servers that should improve server performance considerably. They’re currently being tested in our Testlive branch:

1 Like

@Ignasis, I completed the server report tool you provided, and did not get any confirmation e-mails, receipts or updates whatsoever. There is no evidence whatsoever that anything has happened to the server or acknowledgement of my report.

What to do?

The server report tool is handled and supervised by G-Portal. In cases of performance issues and lag, they usually trigger a restart if there’s some reports telling the same around the same timeframe.
We’ve sent note to our team as well in case there would be some performance blockers in that server in particular.

This isn’t playable.

Ridiculous lag - YouTube

Could you let us know if there is a large presence of player-made buildings, pets and thralls in that server?

Not sure if i can call it lag what is going on since the last few patches.

It’s ever present in singleplayer, where there isn’t a connection needed really. It’s looks to me like a desync often. See this when fighting with thralls.
I shoot an arrow, my thrall behind me run to the ennemis, i shoot a second one, my thrall is again behind me, and running against the ennemis again. Rince and repeat.

There are in some areas, very huge bases. But this occurs in areas where there are no such structures, such as the first video by the lake.

The second video took place in a large base down by the spire in the desert north of the Sentinel statue where there was a very large base.

1 Like

Thanks for the additional information. Our team will look into it and try to determine what’s the cause for it.

The clan has duped thousands of pets on this server, check any of their bases or volcano obelisk for examples and yes they were duped.

Edited out clan name as it is against our community guidelines to share clan or player names.

you try use Debug information to see if you have large Ping ??
If not Try use TooggleDebugHUD

Didn’t use the debug command, but ping is fine:

Server 1977 is just ridiculous too… maybe because of the excess of castles and players,

anyway… the thing is that the server actually is horrible to play,

monsters take a lot to attack you, your pet take a lot to attack too,

many things takes a long time to happen, that make us tired to play like that…

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.