Orangey-green textures

I saw someone else had a similar problem as me - a couple of weeks ago, a few of the textures (a lot of the Filth, a number of the buildings in New York) in SWL turned into this orangey-green colour. It’s not particularly hampering gameplay, but it isn’t great and looks pretty terrible. I updated my nVidia GeForce GT 440 drivers, but that didn’t change anything.

Are there any ideas for what could be causing this? Is there more information that would help explain why this is happening? It just appears to be the textures; I suspect the lighting due to the time of day in-game also is affecting it.

Have you tried running a repair from the patcher?

1 Like

Had a friend having this issue. Repair, and if no good try do a reinstall. You are missing some textures or they ain’t being loaded right if i remember my friends case right.

1 Like

In my experience with troubleshooting similar graphical issues, this is often due to an issue with the graphics card itself. This could be a corrupted driver installation, which could be fixed with a clean driver reinstall. It could also be hardware failure, which we cannot diagnose on our end. Another possibility could be that there are graphical settings being used in the game which are beyond what your card can handle (this to me seems especially likely since the GT 440 is considered an older card). You may want to try lowering certain settings, like the ones highlighted in this screenshot:

If you continue to see the strange colors in-game, then please contact us at We can try to help you troubleshoot this further by email.

1 Like

Yep, I had the same issue a couple of months back. Repair fixed it for me.

Yeah i think for my friend it got fixed when she was forced to reinstall (for other reasons)

Thanks for the ideas. I tried repairing it, and the original textures came back, but now new ones (some trees and cars inBeseiged Farmlands, little things like sacks) are affected. Do you think I should try another repair? I’d like to try what I can before a complete reinstall, because that process will take at least a day.

It’s worth a try, but if it keeps happening you should try to diagnose why your data keeps getting corrupted. That could be something as simple as an overzealous antivirus program or more serious things like malware or failing hardware.

I just figured it’s because the game crashes sometimes, and has been known to take my entire system with it on rare occasions.

Anyway, I repaired again, and then the game crashed when loading after a dungeon, and when I restarted it there was a 400 mb download, and after that the problem hasn’t resurfaced yet. So it seems to have been resolved. Thank you for all your suggestions.