Outdated Client Message on Login

I am running DedicatedServerLauncher 1707 and see the following issue:

“Outdated Client - The match you are trying to join is running an incompatible version of the game. Please try upgrading your game version.”

I was playing this morning, installed the update then this began upon launching again. Where do I get this updated client? Everything downloaded and installed with the patch.

1 Like

Does anyone have any information on this?

I have same issue… says “The Match you are trying to join us running an incompatable version of the game. Please try upgrating your game version”.

This happens right after age of war 4 update and me trying to launch my dedicated server. Any help would be appreciated.

Is there any word on this issue? I am still getting this same message about an outdated client.

This is my own dedicated server. Worked for years just fine and after AoW4 this happens. I am at the loss.

That is same exact issue that I am having. Still no response on how to resolve it. It’s pretty frustrating.

Ok so solution seems to have been found:

Cyberzombie on the Conan Discord helped me work through this and was amazingly patient.

in the branch deployment of the Server UI at the top right there were two things i needed to do
Auto Update on Restart in the dropdown menu and check the Validate Files box

Then he had me update ports in the firewall. I can’t begin to remember the details of that process but it all worked.

1 Like

Thank you. Moment you mentioned ports I asked which ports my brother uses for his CE dedi. server and he has same as mine so that was issue, changing ports made it work. Thank you so much.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.