Out-of-date client

When trying to join the Latin America server now, the following message appears preventing me from joining: "The game you are trying to join is incompatible with your version of the game. Update your game and try again.

It turns out that there is nothing to be updated, there is no content to download. How to solve this, please?

Someone on PC has an update, ours might just take a bit to show up. :weary:

1 Like

same here it for usa private servers as well

1 Like

What now?

now we wait

pc doesn’t have an update and the person that said they did still has the issue,

yea just saw it

1 Like

well at least it’s happening everywhere so it might get looked at sooner than later


Basic Info:

Platform: Xbox One
Issue Type: Other
Game Mode: Online Official
Server Type: PvE
Map: Exiled Lands
Server Name: 2207

Bug Description:

Msg says “Update needed…”

Bug Reproduction:

just try to connect. Xcloud or installed one.

Yes, I saw that after.

As it stands on Xbox we don’t have an update and cannot connect like everyone else on all platforms.

steam here, same issue, cannot conect

Esse problema está em todas as plataformas

Same here xbox isle of siptah 2131

Steam and pc here. I tried may log in and out. Now I’m trying integrity and it seems to have forced an update that didn’t show up before. Anyway still doesn’t work. Same error… Officila server 1035 EU

i have a co player he said he was able to play on some servers and not others he’s trying to find out why he can do this

Same issue here. No update to be seen.

Same here. On xbox… was in a world and it booted me. Since the has continued to give the same error

Same here on PC. Please fix. If you don’t then I’ll actually have to do my job instead! Yuck! :rofl:

I did the unthinkable too and going on a day hike ! I hope the fresh air doesn’t kill me lol