Partial nudity in EU bug still not corrected, Royal armor The sword of Conan still missing after purchasing Siptah and downloadind the new update

Ok so i have purchased Siptah and donwloaded the humongous update afterwards ,but both bugs created by the last update / I am in the EU and play SP / are still there witch is unnerving to be polite , i waited for about a month for a new patch but the max nudity is still partial and my royal armor and sword of conan recipes are still missing since the last update , do i have to wait another month for these bugs to be fixed or will they be ignored and never repaired?

1 Like

Greetings,

Apologies for the inconvenience, we’ll keep working on solving this matter.

Please let us know if you encounter any further issues on our Lands.

This post was flagged by the community and is temporarily hidden.

According to what I read, Its Fixed, But wasn’t ready for 2.4 update. (consoles)

So it’ll return likely next patch.

2 Likes

Oh, fantastic.

Guess we gotta wait for ANOTHER 60GB patch in the HOPES that this is gonna be fixed.

I think I’m just gonna uninstall, and you know, not buy anything for it until you guys get your s**t sorted out. :confused: Exiles already makes it pretty much impossible for me to have more than two games installed on my system.

2 Likes

Mine are there even from the last patch just not in my characters inventory they are in the crafting stations blacksmith and armor benches made my conan sword with a t4 thrall that gives more damage lol still the sword needs a buff to hold its own with these new weapons with poison and others things

I feel ya, I ended up buying an external drive just to keep CE, lol (or tears).

1 Like

Got Atlantean sword here as well, recent patches/updates seem to be affecting dif ppl in odd ways I guess.

1 Like

Yh needs definite buff, game = “Conan” Exiles, sword = one of the weaker (dmg) in game and was preorder bonus.

1 Like

Still get “must be placed on walkable surface” when trying to place thralls near object, and nudity still broken, also red hair is still showing as blond? Home /menu page changed from Exiles, which I play, to Siptah, which I don’t even own? Happy to see stamina change though.

2 Likes

Hi devs. Im play Conan from start,and now i cannot craft royal armor and Conan sword( IM hope you fix this bug very soon. Good luck and thank you! Conan exiles good game.

From playing, more is broken than fixed. Very sad, loved this game a few months ago, thralls just die now so can’t put them in harms way, no combat, no purge, no exploring… no point.

So since we didnt receive a hotfix to address the nude features I am inclined to believe that it wasnt ready like they said it was. Kinda getting frustrated with all this. This was a company who appeared to care about the fanbase. I get there is other issues but if you have one fixed that didnt make cert and said a hotfix was on the way why the delay? I own all content across 2 platforms (steam,ps5/ps5) So I did believe in the developers. At the very least tell us when you plan on the patch coming so people can stop wondering when it will happen.

2 Likes

Same issues Offline solo in Australia. Same frustration too.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.