Password Issues - Can't Log into Game

I’ve changed my Account PW and Game PW - still can’t get into game after waiting 15 minutes. Updated Game PW again and waited 15 minutes - no luck.


This question shows up on the Steam Forums a lot and it’s been reported that it can take up to an hour for the game account to cycle through and talk to the game, so you might just have to wait longer. I know when I had this same problem, I wasn’t waiting all that long, but it did take 3 tries for it to kick in.

Of more use this might be the problem (taken from the steam forums):

You have to make sure that both your e-mail and password contain letters and numbers ONLY.

Your password must be shorter than 13 characters with NO special characters.

I don’t know if I should say the system Funcom uses is older or simple, but the shorter & simplier the better for the password.

Ok - good on just numbers and letters. I’ll shut the game down for now and retry a little later. Thank you!

This is brutal - still not working. Wow.

Anyone have any other ideas?

you need to go to the new age of conan page and reset the password, after they send you new password, you log in using it and then you change ingame password on that page

That worked perfectly - thank you!

you are welcome