Password not enforced on private server

I tried searching to see if there was already any support/workarounds for this issue, but all I could find were posts about correct passwords being rejected by a server. My issue is the opposite, I have set a password on my server, but no-one is ever prompted when they connect to my server. I set the password in the serversettings file.

Any help would be appreciated.

You need to use:

ServerPassword=

in the Engine.ini file for the server password, not the ServerSettings.ini file.

Ahh, thank you for that; I’ll give that a shot soon. What is the server password in the serversetting.ini file for?

Pretty sure that’s not supposed to be in ServerSettings.ini. There IS, however:

AdminPassword=

Which is used for allowing you to access the admin menu once you’re on the server.

Yeah I saw the adminpassword in the defaultserversetting file. I just checked the engine.ini file and there is no lising for any passwords so do I just add the “serverpassword=blah” line item to it or do I need to add something before in square brackets?

Thanks again.

I believe that it belongs in OnlineSubsystem. If you put it directly below ServerName= (wherever that happens to be), you should be good to go. So something like:

[OnlineSubsystem]
ServerName=Village Idiots ★ 1.5x Craft XP ☆ 2x Craft & Harvest Rates
ServerPassword=ScooperIsYourSavior

Looks like I got it working using your help. I was confused between the default files and the config files in the “Saved” directory. I’m not sure what the purpose is behind the “Saved” config files, but I will just edit the defaults.

Thanks again!

1 Like

That will technically work… for a little while. But there’s a very good chance that some (or all) of the changes you make to the default files will be reverted back to the defaults each time the game is patched/updated. Any changes that you make to the files located in:

…\ConanSandbox\Saved\Config\

…should be preserved across updates.

1 Like

Ah, good to know. I shall do that instead!

You can also set the password through in-game server config after activating admin mode (“Make me admin”) and re-opening the settings for the MP server. This should add the entry to the correct file, in the correct place.

1 Like

A post was split to a new topic: Can we allow white listing based on SteamID instead of passwords?

Password protection is like no protection at all, we need whitelisting players via SteamID.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.