PC - Age of Sorcery Chapter 3 Update Discussion Megathread

Je voudrai savoir quel est le thrall qu’on peux mettre dans l’établie de fabrication de golems ?

yes, cant buy anything from the new vendors :frowning:

GUYS are encounters aka evets are disabled completely for now? Seems cant trigger any on EL.
As i remember we got 6 of them, now, we have 0.

That also happens on the sorcery bench. It may be intended?

Someone in the forums wrote that hunger and thirst do not deplete for 10 minutes after eating.

Seriously? I have frigdes full of meat, fish and complete dishes. What does Funcom think we should do with all of this stuff now if we pratically only have to eat twice a day?

Who ever is calling the shots at Funcom, please for gods sake, stop it. Before you break the game completely. This ain´t survival anymore. Not that the game had much survival aspects before. But now it is ridic.

1 Like

Added new entry under the changelog:

5 Likes

The first journey require a character to be level 0.

All other journey paths are open.

if you know the number of horses that I lost before this update…

I had to stop playing with it. because they would die very easily.

I just hope this change is permanent

That health boost was the most insane “fix” I’ve ever heard of. Protect your mount and your thralls when you play. Don’t whine until FC gives the horse more health than the best tank thralls just because we’re too lazy to protect it. Health x 4 = balancing pets and mounts?
Oh hey, can we have 4x the health on all our pets now? That would be balancing. If you want to protect the horses take away the weapons, that’s more logical.

1 Like

How do you explain a horse having twice the health of a greater rhino? I don’t have a problem with a boost to their health but not that much of a boost. I was thinking more along the lines of giving horses a minor attack like a kick or a bite (both real life responses done by horses when attacked).

All the locations worked for me until the volcano. I’ve entered it from various places and no luck at any of them. Do we have to enter the well to complete this journey step?

1 Like

It didn’t work for me until I went to the Road of the Pilgrim POI

Thanks. I’ll try again tomorrow.

What finally worked for me was entering the area via path rather than a cave/portal.

I triggered the journey step by walking down the path beyond the Shrine of the Oracle towards the Black Keep.

Is character Transfer going to be ever available ? me and my friends would like to play on another server

3 Likes
  • New dungeon is a mess of bugs
  • Merchants stopped working
  • The Zar Tiger has no stats (it is a paid item, so it is serious)
  • Should be able to dismantle golem parts
  • improved dismantle bench and improved tanners table are almost a joke. the footprint is huge for practicly no benefit at all.
  • Can’t make the repairing grinder work
  • New journey system is a good idea poorly implemented. It is buggy (as several things of this update) and most of the rewards are crap, few are ok.
4 Likes

See my bug report please.

1 Like

Same for me on PS5 official

Hello guys/gals its a very low importance problem but i have to share with you, (and mocke a little before someone does), its regards armor display and OCP robot cops, and gods brekaers.

As huge fan of robocop, i should ask for it not being fixed LoL.

6 Likes

One more, I think it is a bug (it may be not), but considering all the real grotesc bugs currently reported about the last update this seems fine:

  • the specialized mining storage box from the battlepass doesn’t accept blood crystals.
1 Like