Post-hotfix: Thralls Spawning on Low Health, Server Crashing when Putting Thralls on Wheel of Pain, and More


#1

Game mode: [Online with mods]
Problem: [Crash & Misc]
Region: [US private server]


I encountered three pretty nasty bugs/glitches after yesterday’s hotfix. Some of these may be pre-existing problems.

1: The server often crashes exactly when you press E on a wheel of pain to put a thrall in. It happened twice to me on my server today, and more time to others, and I’m seeing other reports about it on other servers on reddit. It doesn’t always happen, but it happens often enough to be very problematic.

2: Thralls spawn on super-low health after a server restart. Every time the server restarts, whether is for a crash or a scheduled reboot, previously-placed thralls spawn with 100 or so health, then they painfully slowly start healing when the player gets in visual range. They seem to heal ONLY when a player is in visual range (can’t confirm this 100%). This is a similar behavior to when they are placed, the problem is that it happens every time the zone is initialized. It’s absolutely crippling for thralls as a defense. Not only it makes attacking bases more trivial in PvP, but in PvE it gives people a way to damage other players. It’s super-easy to pull mobs on thralls weakened by this bug, and they’ll die in a second because they have only 100 or so HP.

3: Every time a server restarts, all crafting stations stop. This is especially problematic for wheels of pain since they take so long to “cook.” thralls. If you can’t log in right after a server reset, your wheel of pain will remain inactive for hours, and those who can’t play several hours every day might end up taking several days to cook a single T3 thrall even with a T4 taskmaster. Those who have wheels of pain in multiple locations have to basically go to each of them to restart them after every server reset, which is a massive chore. Please solve it so that crafting stations resume work automatically after server restart, without the need of player input.

4 (addition): The white tiger world boss on the ledge north of the Savannah does not spawn anymore. I tested it in an empty single player session as well, and confirmed it, to make sure it wasn’t someone’s build interfering with the spawn. Her chest is still there, so I am guessing it’s a bug and not an intentional removal.


Steps on how to reproduce issue:

  1. Put thrall in wheel of pain
  2. server crashes

Steps on how to reproduce issue:

  1. Log in after server reboot
  2. All of your thralls are on super-low health

Steps on how to reproduce issue:

  1. Log in after server reboot
  2. All of your crafting stations (especially wheels of pain) have stopped.

Steps on how to reproduce issue:

  1. Go to the Savannah
  2. White tiger isn’t there.

Certain Thralls start on low HP when logging back in → Investigating
Server Crashes on PC Official Server #1811
#2

The low thrall health thing happens to me every time I log in whether it is from being off game over night or just a few hours. They are all at about 150 hp.


#3

Can confirm once more the server crashing issue. The server I’m on was 2 minutes away from a daily reset, so I went ahead and tried to stick a thrall in a wheel while it was running (doesn’t seem to happen when it’s not running), and boom. Server crash.

Of course, after the server came back up, all my wheels of pain were stopped, and all my thralls were on 100 health.


#4

I have to clarify that I am playing offline single player. It does it every time I log in.


#5

We had this happen today. Lost a T4 blacksmith as we tried to put her in the wheel… the first one we’d ever gotten :sob:

I actually saw the error during server startup in the log, something about a file for the “Alpha Tiger” not being available or existing. I haven’t seen him in days.

We haven’t experienced the other two issues.


#6

We [EU, PC, rented server from g-portal] also have the wheel-crash, too. Do you use any mods? Among some others we are using LTs compass/minimap and NoxUi rescale. I was thinking it might be due to the UI-mod that resizes the “you are carrying too much” message. That got fixed in the recent patch, so that mod isn’t needed anymore. I am going to disable both once my players log off.


#7

We don’t use either of those mods. I’m guessing it’s a native game related issue.


#8

Wheel crash happens to us too, no mods on server.


#9

I have experienced the server crash when putting thralls in wheel, seems to happen when wheel is turned on prior to ‘e’ ing on the wheel, happened with mods, removed all mods, still happens

here’s the tail end of the log file when it happens

	 [2018.07.09-02.30.11:909][429]Network:Warning: Data: BasePlayerChar_C_0 (server) received 1068.0 bytes per second > 1024 (sample window size: 2.00 seconds)
	[2018.07.09-02.30.23:908][786]Network:Warning: Data: BasePlayerChar_C_0 (server) received 1342.5 bytes per second > 1024 (sample window size: 2.00 seconds)
	[2018.07.09-02.30.28:480][923]LogServerStats: Sending report: exiles-stats?players=1&=26.77%3A33.39%3A113.75&uptime=1200&memory=8127123456%3A68665765888%3A3660849152%3A3730018304&cpu_time=1.475738%3A11.805906&npcailods=8%3A0%3A0%3A5593&buildingailods=4%3A0%3A0%3A0&placeableailods=2%3A18%3A0%3A5&ipv4=199.127.62.91&sport=7777
	[2018.07.09-02.30.35:921][146]Network:Warning: Data: BasePlayerChar_C_0 (server) received 1440.0 bytes per second > 1024 (sample window size: 2.00 seconds)
	[2018.07.09-02.30.36:393][160]PIE:Warning: Warning Invalid Bodies : Make sure collision is enabled or root bone has body in PhysicsAsset.
	[2018.07.09-02.30.52:494][643]PIE:Warning: Warning Invalid Bodies : Make sure collision is enabled or root bone has body in PhysicsAsset.
	[2018.07.09-02.30.55:623][737]ItemInventory:Warning: Data: UGameItem::OnEquip(): Item 'Rock1_C_35' does not specify an EquipSocketName
	[2018.07.09-02.30.55:723][740]LogNetPackageMap:Warning: GetObjectFromNetGUID: Server re-loading object (might have been GC'd). FullNetGUIDPath: [598]EMPTY.[604]EquipmentInventory
	[2018.07.09-02.30.55:925][746]Network:Warning: Data: FunCombat_PlayerController_C_0 (server) sent 1333.0 bytes per second > 1024 (sample window size: 2.00 seconds)
	[2018.07.09-02.31.05:927][ 46]Network:Warning: Data: BasePlayerChar_C_0 (server) received 1044.0 bytes per second > 1024 (sample window size: 2.00 seconds)
	[2018.07.09-02.31.07:724][100]LogNetPackageMap:Warning: GetObjectFromNetGUID: Server re-loading object (might have been GC'd). FullNetGUIDPath: [1398]EMPTY.[1400]ItemInventory
	[2018.07.09-02.31.19:067][440]ItemInventory:Warning: Data: UGameItem::OnEquip(): Item 'Rock1_C_36' does not specify an EquipSocketName
	[2018.07.09-02.31.19:219][440]LogWindows:Error: === Critical error: ===
	[2018.07.09-02.31.19:220][440]LogWindows:Error: 
	[2018.07.09-02.31.19:220][440]LogWindows:Error: Fatal error!
	[2018.07.09-02.31.19:220][440]LogWindows:Error: 
	[2018.07.09-02.31.19:220][440]LogWindows:Error: Unhandled Exception: EXCEPTION_ACCESS_VIOLATION writing address 0x000001c8
	[2018.07.09-02.31.19:220][440]LogWindows:Error: 
	[2018.07.09-02.31.19:220][440]LogWindows:Error: !0x0000000000000000
	[2018.07.09-02.31.19:220][440]LogWindows:Error: 
	[2018.07.09-02.31.19:224][440]LogExit: Executing StaticShutdownAfterError
	[2018.07.09-02.31.19:664][440]LogWindows: FPlatformMisc::RequestExit(1)
	[2018.07.09-02.31.19:664][440]Log file closed, 07/08/18 22:31:19

#10

Exactly same experiencie on our server. Not mods at all.


#11

Commenting for the sake of this still being an issue, the Wheel of Pain crash is making it useless right now.


#12

Bump


#13

Official server pvp 1530 also have the low health issue. Please fix this asap


#14

Do you guys still experience crashes when putting thralls in wheels? Our server had this issue a few days ago, but so far it’s stable again.


#15

I think the issue is if you click PLAY on an empty when and then try putting in a thrall. Still seesm to crash.


#16

On PvE Official 1513 we have the same issue with Thralls being at 100 health after a server restart, I can’t begin to tell you how many Thralls we’ve lost to animals wandering by our base. Most disturbingly though since the Hotfix Thralls will NOT attack when they are attacked or if you get attacked which is part of why we’ve lost a bunch of thralls at our bases and obelisk maprooms. They will run up to the animal/thrall/whatever and just stand there like when you go to someone else’s base but they won’t do anything. Kind of makes the possibility of being purged suck more as you have no thrall defense since they won’t attack, they’ll just stand there with their 100 health and die.


#17

Low health issue is a big one, and also the AI in general is bugged. Thralls and npcs alike will not attack anything or be responsive at all.

THIS IS A HUGE PROBLEM with the purge system active! We can’t always be online during purge hours and thralls are useless to defend our bases now. Either fix these bugs or make purges only happen to online clans…


#18