Problem with connecting to the mod server in Epic Games version

Basic Info:

Platform: PC
Storefront: Epic Games Store
Issue Type: Other
Game Mode: Online Private
Server Type: PvE
Server Name: SILENT LEGION
Mods:
StylistPlus.pak,
Pippi.pak,
No_Building_Placement_Restrictions.pak,
Pickup+.pak,
Emberlight.pak,
RA.pak,
Exiled_lands_improved.pak,
Improved_Quality_of_Life.pak,
immersivearmor.pak,
BarbarianBarber.pak,
SkinManager.pak,
StacksizePlus.pak,
DungeonMasterTools.pak,
ArenaPier.pak,
Shanis-Stuff.pak,
SandAndStone.pak,
Beyond_Decor_II.pak,
3rdCamDist.pak

Bug Description:

When I connect to a server with mods, the game always shows the status “wrong version” next to each mod and forces me to download them again.

This happens even if I copy all the mods directly from the server. And even if I download these mods when I try to enter the server. And also when I installed these mods manually, downloading from the Steam workshop.

For the first time, the game on this server with mods started up normally, it can’t go any further.

The server is on the Steam version.

Bug Reproduction:

Try to connect to a server with mods

2 Likes

Same issue here, and now, to make it worse… the Download All button is greyed out, so i cannot even re-download the mods to log in.
I give up, wasted money buying this, and I was dumb enough to buy the big package… but can’t use it except for local unmodded play

1 Like

Same Here

Greetings dear players!
Thank you for reporting your situations regarding the inability to play with the mods.

Due to our most recent update 3.0, it’s possible that some mods are yet to be updated by their own creators. If that is the case, I suggest you to contact the mod developers in order for them to properly assist you.

Thank you for reaching out to us!

1 Like

Nope.

The error does not depend on specific mods, nor on the way they were added, nor on the server.

2 Likes

Hello again DexSorn.

Since mods are created by the players, I would suggest you to join this discord server Admins United, with specially dedicated private server admins and troubleshooting, in order to get the best support for your issue.

Thank you for reaching out to us!

The issue is independent of any particular mod. It seems to be any and all mods.
I am experiencing this problem from two different PC’s and when connecting to a variety of servers.
The problem did not exist before version 3 released and obviously is not affecting everyone…
Blaming it on the mods is not a valid resolution.

2 Likes

I hope you guys look into this issue, because like I said it doesn’t depend on the contents of mods or servers. And it affects a lot of EGS players.

2 Likes

What is currently known.

  1. The problem affects most (if not all) EGS players. Complaints go to the Discord channels of game servers, not here. As a result, only me and a couple of other people write here, lol.

  2. The problem occurs if there is the slightest inconsistency in the files of the server and the player. Or if there is an error in the modlist. BUT. The game itself does nothing to solve this problem, as it did before 3.0. It does not change the player’s modlist, and also tries to download all the mods from the list in general, even if the error is in only one.

Because of this, at least one server did its own auto-update, which checks the integrity of the files and corrects the modlist. It is absolutely not normal that individual activists make the game playable for others instead of the developers (it’s been a month already, guys). The rest, who do not have such a program, are forced to do everything by hand or not play any mods at all.

2 Likes

I am also experiencing the Epic Games problem with mods constantly indicating ‘wrong version’ and having to reload the entire mod list every time I launch the game and/or change servers. I have my own server and have done some tests…

  1. Running the Epic Launcher in Admin mode has no effect on the bug
  2. Uninstalling and reinstalling Conan Exiles, including deleting the ConanSandbox\Saved\ModRestartData.json; ConanSandbox\servermodlist.txt and ConanSandbox\Mods\mod files. No effect on the bug
  3. Since I control the server, I restarted it constantly through tests
  4. The Steam version of the game tracks Conan mods by numerically titled folders with “.pak” files within that are named after the mod, such as “Emberlight”. The Epic Games version of game tracks mods by a numerically named “.pak” file. Before 3.0, the Epic Games version used “.pak” files named after the mod. Perhaps whatever drove this change is causing the bug.
  5. I can launch Conan, select a server, load all the mods, play the game successfully, exit the game to the main menu, select the same server and immediately log back in and EVERY mod is marked as wrong version.
  6. On a side note, reloading all the mods on the server I used to test this problem takes minutes through Steam, and hours through Epic Games.
  7. Epic Games support worked with me a little before pointing me to Funcom. Please help! Having to reload the mods every time I want to play makes it unplayable, especially with the load times required to do so through Epic Games. Thank you!
2 Likes

Basic Info:

(Why are the sub-tags only Steam, Gamepass, and Win10? Epic Games is not even listed. Had to select “Steam”, but this is an Epic Games problem)

Platform: Epic Games Store
Issue Type: Other
Game Mode: Online Private
Server Type: PvE
Map: Isle of Siptah
Server Name: “Eternal” and other servers
Mods: Fashionist v4.40; Better Thralls v2.1.1; Stacksize Plus v1.8.0; Devious Desires; Sudo; Exile Thrall Wars Utilities; Thrall Wars Decorations; Thrall Wars Dungeon Mod; ExilesExtreme v1.5.40; Beyond Stations Beyond the Forge; Beyond Décor: Rustic Edition; Beyond Décor Beyond Theatrics - A scene composition mod; RA: Character Customisation Emberlight 3.3.3; Improved Quality of Life 3.4.8; GrimProductions; Nocturnal Gods: Clothing and Accessories Immersive Armor (3.2); Barbarian Barber vers. 3.6.2; Female New Faces; Male New Faces; Kerozards Paragon Leveling - Reloaded - v2.3.7; High Heels System 3.2.5

Bug Description:

Launching Conan Exiles from Epic Games causes repeated error of “wrong version” for all mods associated with a server. Using the Epic Games launcher, accessing any server with mods causes an error of “wrong version” for all mods on the server. After all mods have been updated, the game can be played normally. Exiting the game to the main menu and immediately logging into the same server results in the same error, “wrong version” for all mods, and they all have to be updated again. This problem does not exist when Conan Exiles is launched from Steam to access the same server. Spending hours updating the same mods on the same server every time you want to play makes the game unplayable. The server identified for this bug is just an example. It happens on multiple servers tested by me, and possibly every server with mods.

Bug Reproduction:

Experiencing the Epic Games problem with mods constantly indicating ‘wrong version’ and having to reload the entire mod list every time I launch the game and/or change servers. I have my own server and have done some tests…

  1. Running the Epic Launcher in Admin mode has no effect on the bug

  2. Uninstalling and reinstalling Conan Exiles, including deleting the ConanSandbox\Saved\ModRestartData.json; ConanSandbox\servermodlist.txt and ConanSandbox\Mods\mod files. No effect on the bug

  3. Since I control the server, I restarted it constantly through tests

  4. The Steam version of the game tracks Conan mods by numerically titled folders with “.pak” files within that are named after the mod, such as “Emberlight”. The Epic Games version of game tracks mods by a numerically named “.pak” file. Before 3.0, the Epic Games version used “.pak” files named after the mod. Perhaps whatever drove this change is causing the bug.

  5. I can launch Conan, select a server, load all the mods, play the game successfully, exit the game to the main menu, select the same server and immediately log back in and EVERY mod is marked as wrong version.

  6. On a side note, reloading all the mods on the server I used to test this problem takes minutes through Steam, and hours through Epic Games.

  7. Epic Games support worked with me a little before pointing me to Funcom. Please help! Having to reload the mods every time I want to play makes it unplayable, especially with the load times required to do so through Epic Games. Thank you!

2 Likes

Same problem. I have a modded server and I log in to it with my Steam client. I bought the game also on Epic an tried to log in with the new account. It downloaded the paks and then low an behold: “wrong version” :slight_smile: .
I found a solution though… I copied the contents of steamapps/workshop/content/440900 to the Mod folder in WindowsNoEditor/ConanSandbox of my Epic install. Then, I modified the modlist.txt in the Epic install to match the exact order of my server. You can find that in your Steam install servermodlist.txt (if your last log from Steam was to the server you’re trying to log to): steamapps/common/Conan Exiles/ConanSandbox/servermodlist.txt.
Of course, the absloute path in servermod list points to your steam workshop path and you need to replace that with your Epic install Mod folder in modlist.txt in the Epic install.
Note: I tried first using the steam workshop path in my Epic install, the game loaded (after a long loading time) but the Epic servers didn’t allow me to login to online services (I suspect BattleEye and loading mods from another folder then the Epic install). Once I copied the mods in the Epic install and replaced the path in modlist.txt it worked.
For Funcom devs and support : this is not a mod issue guys. It’s the way the server and client understand paths for loading mods. Get your stuff together.
For people who want to buy the game from Epic and log in to server with mods: fiend a friend with Steam until Funcom addresses this :grin:.

1 Like

Bumping this. Every time I log in with my Epic version of Conan Exiles to my modded server I am forced to re-download every mod. I hope the devs have this on their radar somewhere.

This issue still exists, so bump…
I am to the point now I rarely bother playing, it takes too long just to get in anywhere except vanilla… all the Fun has gone out of Funcom.

Working with Steam account and Epic account for Conan to see why the Epic version keeps reloading all the mods. Several options have failed (Modlist, ModControllerCache, copying mods from Steam to Epic, etc.). Here are lines from the game log showing errors just before it starts reloading all mods. After the following, the reloads begin. Maybe a clue to the real problem?

  • ConanSandbox:Display: Server mod list received
  • LogNetSerialization:Error: String is too large
  • LogSerialization:Warning: FArchive: String is too large
  • LogNet: NetConnection::Close() [PendingNetDriver] [NoPC] [No Owner] from NMT_Failure ModMismatch
  • LogNet: Player disconnected: Unknown
  • LogNet: UChannel::Close: Sending CloseBunch. ChIndex == 0. Name: [UChannel] ChIndex: 0, Closing: 0 [UNetConnection] RemoteAddr: 144.126.153.156:35500, Player name: Unknown
  • LogNet:Error: Failed to read control channel message ‘Failure’
  • LogNet:Error: UControlChannel::ReceivedBunch: Failed to read control channel message
  • LogNet:Warning: Network Failure: PendingNetDriver[PendingConnectionFailure]: ModMismatch
  • LogNet: NetworkFailure: PendingConnectionFailure, Error: ‘ModMismatch’
  • Then this message for each mod…LogPakFile: Pak file D:/Program Files (x86)/Epic Games/ConanExiles/WindowsNoEditor/ConanSandbox/Mods/1159180273.pak was never used, so nothing to unmount
  • Except for one…LogModManager: UModManager::LoadModInfo: Failed to Validate mod: D:/Program Files (x86)/Epic Games/ConanExiles/WindowsNoEditor/ConanSandbox/Mods/1701455174.pak

Basically same info as xjade reports
Except my system loads the mods by name rather than number.

[2022.11.24-18.57.17:361][730]LogPakFile: Pak file D:/Games/Epic Games/ConanExiles/WindowsNoEditor/ConanSandbox/Mods/Pippi.pak was never used, so nothing to unmount
[2022.11.24-18.57.17:549][730]LogNet: DestroyNamedNetDriver IpNetDriver_1 [PendingNetDriver]
[2022.11.24-18.57.17:549][730]LogExit: PendingNetDriver IpNetDriver_1 shut down
[2022.11.24-18.57.39:134][770]ConanSandbox:Warning: Not enough time has passed, using cached entitlements.
[2022.11.24-18.57.39:157][770]LogOnline:Warning: OSS: Can’t destroy a null online session (Game)
[2022.11.24-18.57.49:475][175]LogOnline:Warning: OSS: Can’t cancel a search that isn’t in progress
[2022.11.24-18.57.49:475][175]ConanSandbox:Display: Joined online session ID: 6860
[2022.11.24-18.57.49:476][175]LogNet: Browse: (IP Here)//Game/Maps/Startup?Password=xxxxxx
[2022.11.24-18.57.49:476][175]ConanSandbox: PrePendingNetGame_Callback 144.48.104.149:7783//Game/Maps/Startup?Password=xxxxx
[2022.11.24-18.57.49:476][175]UnitTest:Display: ClientState: 1
[2022.11.24-18.57.49:476][175]ConanSandbox: RefreshAsyncLoadState [Static asset finder] Time: 0.000000 [s]
[2022.11.24-18.57.49:477][175]ConanSandbox: RefreshAsyncLoadState [Map data] Time: 0.000000 [s]
[2022.11.24-18.57.49:477][175]ConanSandbox: RefreshAsyncLoadState [Game tables] Time: 0.000000 [s]
[2022.11.24-18.57.49:477][175]ConanSandbox: RefreshAsyncLoadState [Granite precaching] Time: 0.000000 [s]
[2022.11.24-18.57.49:477][175]ConanSandbox: RefreshAsyncLoadState [Audio] Time: 0.000000 [s]
[2022.11.24-18.57.49:477][175]ConanSandbox: RefreshAsyncLoadState [Mod controllers] Time: 0.000000 [s]
[2022.11.24-18.57.49:477][175]ConanSandbox: RefreshAsyncLoadState [Done] Time: 0.000000 [s]
[2022.11.24-18.57.49:477][175]ConanSandbox: PrePendingNetGame_Callback end. Time taken: -0.388080 [s]
[2022.11.24-18.57.49:477][175]LogInit: WinSock: Socket queue 32768 / 32768
[2022.11.24-18.57.49:477][175]PacketHandlerLog: Loaded PacketHandler component: Engine.EngineHandlerComponentFactory (StatelessConnectHandlerComponent)
[2022.11.24-18.57.49:477][175]LogNet: Game client on port 7783, rate 25000
[2022.11.24-18.57.49:477][175]LogNet: UPendingNetGame::InitNetDriver: Sending hello. [UNetConnection] RemoteAddr: 144.48.104.149:7783, Name: IpConnection_2, Driver: PendingNetDriver IpNetDriver_2, IsServer: NO, PC: NULL, Owner: NULL, Player name: Unknown
[2022.11.24-18.57.49:477][175]LogLoad: TickWorldTravel finished. Time taken: -0.387485 [s]
[2022.11.24-18.57.49:498][177]LogHandshake: SendChallengeResponse. Timestamp: 35571.019531, Cookie: 021231013040104068048131078138158018239063074031248073174206
[2022.11.24-18.57.49:546][183]ConanSandbox:Display: Server mod list received
[2022.11.24-18.57.49:546][183]LogNet: NetConnection::Close() [PendingNetDriver] [NoPC] [No Owner] from NMT_Failure ModMismatch
[2022.11.24-18.57.49:546][183]LogNet: Player disconnected: Unknown
[2022.11.24-18.57.49:546][183]LogNet: UChannel::Close: Sending CloseBunch. ChIndex == 0. Name: [UChannel] ChIndex: 0, Closing: 0 [UNetConnection] RemoteAddr: 144.48.104.149:7783, Player name: Unknown
[2022.11.24-18.57.49:546][183]LogNet:Warning: Network Failure: PendingNetDriver[PendingConnectionFailure]: ModMismatch
[2022.11.24-18.57.49:546][183]LogNet: NetworkFailure: PendingConnectionFailure, Error: ‘ModMismatch’
[2022.11.24-18.57.49:741][183]LogNet: DestroyNamedNetDriver IpNetDriver_2 [PendingNetDriver]
[2022.11.24-18.57.49:741][183]LogExit: PendingNetDriver IpNetDriver_2 shut down
[2022.11.24-18.57.53:705][749]LogModManager: Requesting direct server download for non-Steam Mod ‘Pippi - User & Server Management - v3.9.3’ (0801b059c706b04fd17951f83f959de7)

Any update or is this on any radar to get fixed? Because I bought this after seeing some of the mods and after trying all the lengthy hoop jumping “fixes” that didnt work. I cant refund it…