Problem with Private Servers and loading in objects. Player included

So about a month ago I have been running into this problem where I can log into a private server but the game refuse to load in objects. From my character, to the chat, to any items around me.

Normally, I could start up and after about 2min MAX everything would be loaded in. But now it takes 20+mins up to never loading at all. If stuff do load in, if i pull brac or die it starts all over again

Also when other players are standing in front of me they are either not there on my screen. Or when they are there in front of me, if the other player were to move they remain right in front of me on my screen. If I were to move, they would see me move.

It is like my game refuses to receive packets or something.

For troubleshooting,
I have reinstalled game, mods, and steam. I have built a new pc during this problem so I had a blank ssd and started from scratch. I have deleted mod lists, I have done everything imaginable

PC issue? I had no problem before it all happened but once it started I tried on other pcs

  1. rzyen 5 3600 rx580 16gb ram
  2. ryzen 9 7000 rx5800xr 32 gb ram
  3. Laptop integrated gpu 8gb ram
    Again all same issue therefore not a pc issue

Internet check:
Internet : 400down 40 up 30ish latency

I have used VPN, port forwarded, replaced router, went thru wifi. thru router port, direct plug in to Point of Entry. Again no fix

This problem is on ALL servers.

As for other games. I can play every other game online with ZERO issue. No lag, no disconnects, no problems whatsoever.

Now I have been mentioned it might be my ISP, someone had a similar issue and when they replaced ISP they said it fixed the problem and never had an issue since.
Ive had this same ISP for years, so its odd that it just up and stopped working.

I was wondering if anyone else ran into this issue, because I cant find similar problems scouring the internet.

I got the same issue, but it is only with certain players, and when they are near me, the entire area glitches out. I tried alot and its brought me to the point of not wanting to play anymore. I do not know shit about pc’s. no fixes are shown on internet. Did you manage to solve the issue? And what is a ISP

Are you absolutely sure about this?
Because by your description this sounds like the typical “bad quality server” (most likely hosted on gportal…) that’s using mods when the server machine can barely run the vanilla game :stuck_out_tongue:

Ofc your internet connection to that specific server could also present similar issues.
What about other players on those servers, is everything just smooth for them?

The chat is not an object… so what specifically isn’t loading about it? the UI itself? or just the messages… because if it’s the first one then there’s some other issue.

Do you happen to have any silly antivirus software or third party firewall? If so, disable those.

Placeables, inventories, and chat taking a while to load in is normal on heavily modded servers, especially if they’re running on weak hardware. We have a similar issue on my server (not a cheap gportal VM, but one of the more expensive dedi options from GTX) where most of a player base (the building pieces) will sometimes be invisible and never render in for a player unless that player shoots an arrow at it. We always assumed that it was some issue on our end, something wrong in our config or possibly a mistake I’d made in the server mod. If that’s affecting anyone else’s server I’d be quite interested in talking about it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.