PS4 Twitch Drops Take 2 (post patch 2.4.6)

Game mode: Online private
Type of issue: Other
Server type: PvP
Region: Oceania
Hardware: PS4 Slim

Bug Description:

Unable to successfully link Twitch Account.
Good news*: it looks to be a problem with the PS4 web browser & Twitch not getting along.

Expected Behavior:

Linkage of Twitch Account and Twitch Drop campaign items available to craft in game

Steps to Reproduce:


    • Disconnect the Conan Exiles Account Link on the Twitch side for a clean slate
    • Download & install 2.4.6
    • Restart after install just to be on the safe side

Connect Twitch Account

  1. Select Link Twitch Account from main menu
  2. Click Link Now
  3. Click Authorise
  4. Error Returned: Unable to link Twitch account. Pllease try again later. Error Code : -2147024809

Post Error Checks
As with the initial failure, a second attempt to link the Twitch account returns the following message:

This account is already connected to Twitch.
To disconnect your Twitch account visit Connections settings on Twitch webpage:
or open it directly now:
(link to Twitch)

I clicked through with the intention of unlinking both the Conan link and the link to my PS4 – thinking maybe there was something in the (presumably cached) PS4 browser authorisation and noticed something… odd.

There are elements of the page not coming through to the PS4 Browser window, including

  • my profile image
  • list of followed channels and (importantly?)
  • any of the ‘Other Connections’ listed - including the Conan Exiles Account Link

The panels that should display those connections instead present:
Extensions Connections: ‘Sorry, something went wrong fetching your extension connections. Please try again later.’
Other Connections (where the Conan Exiles Account Link should be listed): ‘Sorry, we couldn’t fetch your authorized apps right now. Try again later.’

I’m on a pretty decent fibre connection, so at this point I’m thinking it’s a browser issue - so we’ll run through the basics for clearing that out of the way.

So I’ve opened up the Browser app on the PS4 and ran through the following:

  1. Select Options Menu and ‘Delete All’
  2. Select Options Menu and select ‘Browsing History’
  3. Select Options Menu and select ‘Clear Browsing History’
  4. Go back and from the browser main screen select Options Menu, then select Settings
  5. Select ‘Delete Cookies’
  6. Select ‘Clear Website Data’

Then I’ve gone back to Twitch on my laptop and removed the link from there.
(insert 10min wait for stuff to make its way through the intertubes, restart the PS4 again for kicks. I probably should have scrubbed the saved Conan Exiles data around here as well just to be thorough, but skipped it because I needed coffee.)

extremely Julie Andrews voice
which will bring us back to…

Connect Twitch Account

  1. Select Link Twitch Account from main menu
  2. Click Link Now
  3. Log In to Twich (indicating the deletion of browser info did what it was supposed to)
    (Repeat 3 because I’m a dolt and forgot I changed my password a while back)
    3.1 Enter 2FA Token (which probably won’t be of any significance but a gentle reminder kids - 2FA all the things!)
  4. Wait what seems an eternity for Twitch authentication to complete
    4.1. I’m 5 mins in at this point and the Token entry page is still up… but the Successful Login Email landed about the same time I clicked the button. (This is really leaning towards an issue between the PS4 browser & Twitch at this point)
    4.2. Check the Connections page on the laptop to see if the Conan Exiles Account Link has landed there (it hasn’t)
    4.3. Still waiting, realise there are a couple of possible app links from the Playstation that might confuse the browser authentication attempt
    Recommended Connections > PlayStation® Network
    Other Connections >Twitch for PlayStation® 4
    4.4 Decide to ignore them
    4.5 Okay 20 mins waiting for the Log In screen to move on at this stage, and any API stuff under the hood has definitely timed out already.
  5. Refresh the Log In window
  6. PS4 browser window bounces between a logged in window and the Login screen a few times. It’s definitely confused. I’m Schrodinger’s Twitch user at this point.
  7. Close the PS4 Browser window
  8. Hit ‘Link Twitch Account’ from the Conan Exils main menu again.
  9. Get the ‘This account is already connected to Twitch’ message (which unlike previous instances, is not even partially accurate - the connection doesn’t show Twitch side at all. I suspect that somewhere down the line a 200 response meaning ‘yep we got this request’ is being incorrectly interpreted as ‘yep, this request was completed’ and that’s being shot in client side as a successful linkage. Also happens a lot where there’s more than one call made downstream.)
  10. Open the Twitch settings page from the prompt
  11. Connections page blerks out because I’m not logged in
  12. Login popup is thrown, attempt logging in again
  13. Not even asking me for 2FA now, it’s hung on the initial login attempt (strike 3 for a PS4 browser app issue). ‘Successful Log In’ email comes through though.
    13.1. Try to bounce around the Twitch site a bit looking for a different login path - as with 6., PS4 browser keeps trying to use passport-callback to open the page as if I’m logged in but the module fails to load because that authentication was evidently unsuccessful.
  14. Close out the browser window, close Conan Exiles, reopen Conan Exiles
  15. Try linking again - this time it passes me through to the Authorisation page (so the login that appeared to have failed on the last run has now been successful browser side. Not infuriating at all.)
  16. Click Authorise - receive original error (-2147024809)
    17… decide to come back to this on my lunchbreak for another shot after having cleared all PS4 connections Twitch side and rescrubbing the browser data on the PS4.

Same problem here. After Funcom said the fixes for twitch drops would come with the next Playstation update, I waited and waited for months, but I had hope. Logged in today to download the update (finally…), only to find out that nothing has changed?
I thought well, at least I can use the Watchers armor (twitch drops) now, but also a nope on that side.
So I disconected my Twitch account, thinking that maybe reconnecting would fix it … only to end in the same loop as you.
It’s frustrating. Me and my friend started our own server with the Isle of Siptah release, only to find a broken and in some instances unplayable game.
I don’t know what to say anymore… I used to love the game, and I still do, but in times like these, it’s hard not losing hope.

1 Like

Same issue here on ps5, however if you view the page information it gives you the url of the page. After spending some time copying it letter by letter I got on my phones browser to the link page and received the same error message minus the error code part. So it either errored out cause my phone isn’t a ps5 or there’s something wrong with the link from the console to twitch.

Yep. I tried it on ps4 a while ago and today on ps5. Same result.
Btw: after countless error codes and everlasting loading screens it still didn’t work, however Twitch says it’s linked now.
Not that it would change anything. Drops are still bugged.


Same here. Still no twitch drops even that I redeemed them on twitch in May. They said it will be fixed in the next update … nothing has changed only one armor got in game and thats all

1 Like

same here. No twitch Drops for me. Claimed them in may.
funcom, please!

1 Like

That link will include an authentication token unique to the session you’ve opened on the console - bait 'n switch won’t work I’m afraid.



  1. Disconnect the Conan Exiles Account Link on the Twitch side

  2. Disconnect all PS4 connections Twitch side

  3. Clear all PS4 brower app data

  4. Delete Conan Exiles User Data

  5. Shut Down the PS4 for a bit
    [a full work day of similar insanity later…]

  6. DLC panels are up, so Restored Licences to avoid any new suffering

  7. Decide to disable 2FA on Twitch just to ditch a possible point of failure
    [get really annoyed that the numbered list above shows as 1 & 2 in the input box, but 6 & 7 in the preview, but move on for the sake of one’s sanity]
    [deep breath]

  8. Log In to Twitch from the Main Menu

Fun fact - if you’re logging in from a ‘new’ device, Twitch will send you a verification code anyway.
Not quite the same as the opt in 2FA code; just enough to confirm you’re not a bot.
Not so fun fact - the soft keyboard on PS4 really doesn’t understand how the single character fields to enter those numbers work. I’d suggest using a keyboard if you can.

  1. Twitch login hangs on the simpler-but-no–less-annoyingly-placed additional verification step on this run.
  2. Close the browser window, try again
  3. Asks me to link again, so nothing accidentally stuck client side of the game* at least?
  4. *correction - seems to be a check made via the site that determines if you’re linked already or not
  5. This time I get the authorisation prompt (sigh, I can see where this is going), so the browser login attempt has stuck, and was successful despite the post verification hanging
  6. Select Authorise, receive -2147024809 error

pour self a drink

  1. Select Close
  2. Select Link Twitch Account
  3. Click Link Now
  4. …wait what? The link is showing Twitch side, that shouldn’t be there - the connection went through according to the Twitch connection page…
  5. Disconnect on Twitch side out of spite
  6. Link Now
  7. Authorise
  8. -2147024809 error
  9. Clear browser cookies (but not website data)
  10. Try again.
  11. Fail again.
  12. Poke around a few variations
  13. Wonder if the response_type should be token instead of code at that point in the flow
  14. Realise you’re definitely not clever enough to know but have a read of the twitch dev stuff anyway. Be astounded at how truly deep your own ignorance of stuff actually runs, and frustrated that the PS4 browser won’t let you select the URL to take a proper look.
  15. Curse Crom and his devils

I have the same issue…

I think the system that Funcom came up with for the Twitch Drops is strange anyway, why do you have to do this in the internet browser, why is there no way to create an account in Conan itself that you can then connect to Twitch normally or the link simply via the connected PlayStation Network account works?

In my opinion
the simplest solution to the problem would be to simply implement the items permanently for everyone in the game on the PlayStation in the next patch and best not to bring any new Twitch drops.

1 Like

… is a bit of a misnomer. The system is Twitch’s, and relies on the use of client specific URLs to connect & authenticate. The Conan part of that equation (as the client) is the site you’re directed to where the ‘Link to Twitch’ button sits.


I tried as well on my own, followed your steps and even tried the suggestions from the pre-patch and still nothing.

Im pretty sure the drops do work now, this has to be an issue with linking? I jumped into SP to test - I can craft and use the Watchers set, I did all my linking back during the event. I dont recall the exact steps I took, but I followed the advice of the Dev post that was made.


I only tried it on a server so far. Going to test it in SP later. Thx for the info.

1 Like

It’s not working for me on SP it’s not on feats or benches.

Also, although I can search for the items, I can’t spawn then with the admin menu.

If you used admin than this is irrelevant. It’s visible for most of us using admin controls. In any other circumstance including official it’s still not working.

I could craft them and had recipes for them in my feat list and on the armorers bench - first picture. I thought before they could only be admin spawned, but not actually crafted. Is that not the case?

1 Like

Nah most of us can’t even admin spawn them.


What ever items I earned can’t remember I don’t want bad enough to go through what you guys are good luck.


It’s clear at this point that funcom has no idea how to fix it. As much as I love feeling special like I got something exclusive for my time spent, I’d much rather they just unlock it for all ps4 users and never do twitch drops again.


I can craft them in SP and can spawn them using Admin panel, but have no idea how to gain access to them in multiplayer…