Unable to craft Twitch drop items (items not found)

Game mode: Online official (also tried Single-player and Co-op)
Type of issue: Bug
Server type: PvP and PvE
Region: US
Hardware: PS4 Standard


Bug Description:

Unable to find Twitch drops after following instructions for linking the game to twitch, watching streams, and claiming drops. Instructions followed as per original post: Conan Exiles Twitch Drops: May 27 - May 31 :pogchamp:


Expected Behavior:

I expect to see the drops on my hand craft inventory or on the feats menu.


Steps to Reproduce:

  1. Link twitch account to game, using the in-game link on the start page of the client.
  2. Watch twitch streams with drops enabled for 2 hours
  3. Earn drops and successfully claim the drop
  4. Drops do not appear as craftable items.

4 Likes

What’s your twitch drops menu look like? Mine looks like this after today’s three drops:
image

If those boxes still have “connect” buttons underneath then there’s a step missing. If there’s checkboxes underneath the claims then you should have them, assuming you linked the correct account.

The Gloves of the Watchers is found under Armor → Exile Epics and the Touch and Banner are both under Decoration → Furniture Maker.

1 Like

Same problem here. Account linked, drops claimed but do not appear in feats, craft menu, artisans table or armourers bench. Ps5.

7 Likes

I play on a 1tb ps4 slim, I have followed all the steps mentioned above and I have not received the objects obtained in twich, I must also say that I know two colleagues who have not received the objects after linking their accounts with twich and claiming them drops.

8 Likes

PS4, some details here.

3 Likes

Hmm okay, will relay this thread and @Pr0mythean’s reply over to Slack and when folks are back online tomorrow morning we’ll look around some more. Thanks yall, sorry for the trouble.

6 Likes

I use it through android, it even tells me that the game bowl is connected.

2 Likes

I started to add pictures to the orignal post, will add a few more later. Thank you for looking into this.

4 Likes

I have the same issue as h3rb1 on PS4 (Error Code:1012) when i startet the Game and instantly try to reconnect my Conan Account to Twitch in the Main Screen.

This is showing up to me in the Main Screen when i try to reconnect my Conan Account to Twitch (After a Singleplayer/Coop/Multiplayer Game):

When i click on the button [Open Twitch Settings Page] it leads me to my linked Accounts on Twitch and the Conan Account is there but i dont get the Twitch Drops in Game.

3 Likes

I have the same problem, my account was linked perfectly, but after I didn’t find the items, I tried to click on link again, and the same error appeared, Error Code: 1012

I hope you find a solution, as I was very excited about this event, and now I am afraid of losing the items

1 Like

Same here account linked watched 2 hours no items. Try to admin spawn to see what they look like. Failed to spawn item. Item not found. Ps5. As bad as it sounds I am glad I’m not the only one with the issue.

3 Likes

I understand it’s already being looked into.
Just chiming in that I’m having the same issue.
Check marks in my Twitch account, connect through my PS4.
Most unfortunate.

2 Likes

Many of you are way ahead of me, I am not able to link my Twitch account at all. The link on the main menu does nothing when I interact with it nor does that webpage I followed from Twitch that say Connect Now. Is my AdBlocker interfering with both, maybe?

1 Like

Hello everyone,

Can you try the following and see if it helps?

  1. Click the Link Twitch Account button in game main menu
  2. Click the Open Twitch Settings Webpage button and verifying that there is no connection to Conan Exiles. It is important to do this in game, if there are any problems with differences between Twitch and in game status of linking.
  3. Close the Twitch webpage and wait a few seconds.
  4. Click again on the Link Twitch Account button in game main menu

If there is still information about already connected Twitch account, try to log into any server and then go back to main menu.

Also please keep in mind that you cannot see the rewards if you don’t have prerequisite feats yet.

3 Likes

Thank you same here me and another watched Hundred year bore I already follow him for years and no drops in game. We reset everything game and the console it self even and no drops the armor looks dope though hopefully it gets fixed

1 Like

I followed what you said and my items are in game thankyou also I reset console again not sure if that helped or not but the gloves torch and banner are there again thank you so much :star_struck:

1 Like

Xbox ¿? Ps4 ? :S
I Disconect link and reset game, Link Account new. No armor, flag and drops. O.o

1 Like

Sorry but what are the prerequisite feats?

2 Likes

I will try this later today.

I followed the above steps/instructions. My Twitch “connections” page shows a Conan Exiles account link. When I click “Link Twitch Account” from the game menu, I get a “Twitch connection already established” message. The items/drops do not appear when searched for in “feats” or on artisan workbenches, etc. I have been attempting this with a level 60 character (all appropriate feats unlocked) on an official Exiled Lands server using a PS5.

EDIT: I should have added that on my Twitch account’s “drops” page, all three of yesterday’s drops appear with checkmarks beneath them.

2 Likes