Purge broken after latest patch

Game mode: Single-player
Type of issue: Bug
Server type: PvE
Region: US
Mods?: Yes
Edition: Steam

Bug Description:

The purge meter has stopped climbing and the purge will not start and cannot be started with the console command StartPlayerPurge.

Expected Behavior:

purge meter should climb as a result of killing npcs. Purge should start.

Installed Mods:

If you answered ‘Yes’ to using mods, please list all your active mods. Otherwise, skip or delete this section.

Aquilonian Females
Topfreedom 2
Out of the wheel
Better Thralls v 1.9.16
Dismember Me Not V2
Emotes for Thralls v2.1.5
Sane Consumable Weights
Less Building Placement Restrictions 7.3.0

Removing all mods does not cause purge to occur.

Steps to Reproduce:

Uncertain. I had a sizable base using only stonebrick fence foundations as foundations (along with walls, ceilings / doorframes, etc.) and I set the purge requirement to 50,000 points early on. I was repeatedly cleaning Sinner’s Refuge to increase the purge bar. Purge bar passed the first marker and turned purple, but after a few more run throughs, it stopped increasing. At this point, it was perhaps 1/10th - 1/8th of the way between the lower marker and the maxed out bar.

I tried a number of things to trigger the purge, but none worked. The purge bar has not increased since, and it has been several days.

Empty the bar, refill the bar using commands. Force purge start, keep typing it in until you see the bar empty.

Emptying the purge meter (via EmptyPlayerClanPurgeMeter) works.
FillPlayerPurgeMeter does not work, but FillPlayerClanPurgeMeter does not.
StartPlayerPurge does not work. I’ve tried several times with the bar full.
Also, the purge is not starting on its own when the bar is full.

After I emptied the purge meter, it did start growing again. We’ll have to see what happens when it reaches the purge level.

Purge is still not starting. (I set the update interval to 1 minute and the purge value to 1400 to test it.)

If I’m correct, StartPlayerPurge is not enough, you have to type the purge type and the wave, and a number (number of the wave) after it in. Something like this: Help with purge commands - #4 by science
I don’t use it anymore, but when I found that reply I played with it for a week or so. Don’t know if the command is the same.

They do. I’ve tested this hundreds of times over the years. Not sure what you are doing wrong, just tested it (again), works fine.

This one is messing up for me as well. But I am testing it modded, I’ll have to try again on a vanilla save later when I have more time/energy.

So alternatively, here is what I did to get it to trigger.

  • EmptyPlayerClanPurgeMeter
  • FillPlayerClanPurgeMeter
  • Slomo 100
  • Wait ~ 30 seconds and it triggered

Other key points? Make sure your base is actually big enough to trigger a purge in the first place.

And how long did you wait? A full purge meter with a 1 minute interval does not mean it’ll start in 1 minute. Hence why I use slomo 100 when testing the Purge.

Your base is on noob river, the large river in the south? if so this is why, since the new patch there are no purges along noob river.


Like CrazyReplicant stated Funcom thought it was a good idea to prevent purges from occurring anywhere South of Noob river so if you built a base there and want purges you will have to start building all over again or wait for a talented modder to come out with a solution. I personally just put a ton of time into a build in the jungle area and haven’t been on since reading the patch notes but I am confident a mod will probably be made to revert this unfortunate decision.

I got so creamed by a purge yesterday. Stupid Kitchen Sink purge…

OK, thanks. I did not see that in the patch notes. They really need to think about how their changes will affect single player play.


I waited until the bar completely filled. Usually, the purge has started within 5-10 increments after turning purple, but it absolutely should trigger when it hits the top of the purge bar. (In the past, if the purge meter overfilled, it would never trigger the purge unless you increased the purge limit to above your current purge meter value.)

It never has been a guarantee. Logically it makes sense (from a players perspective), but code wise it doesn’t work that way.

Sounds like you just missed the notes about the Purge no longer being eligible in the noob River region. You’ll either need to make a mod, or wait for one to be made (its on my more immediate to-do list. I saved the old Purge table before the update occurred for that reason.)


I am not sure if the position of the base is the issue here. We made a new server on friday and have the same issue with purges.
Our base is on the border of F4, F5 and our purge meter is full since friday now. Purges are set to trigger with 1 person online and nothing happens. Even starting one over Admin tools doesn’t have an effect.

Same at our server since update, purge wont trigger.
My base have had plenty of purges until now, located at A8 (Exile Lands)

1 Like

Hi there! I’ve run into a similar issue. I am running similar mods. My purge progress bar has advanced to the max, been there for about a week, no purge. How far off of noob river did you have to go to build?


We build a second base further up in the north (D11 Exiled Lands) and still don’t get purges.

Emberlight 3.1.9
Aquilonian Passion Body
Fashionist v4.1.2
RA: Character Customisation
Improved Quality of Life 3.3.1
Kerazards Paragon Leveling
Stacksize +
Less Building Placement Restrictions

Purge Meter is full. Starting purges with “StartPlayerPurge” isn’t working. “EndPurge” shows only that a purge has ended, but with not specification of what purge it was. Normally it’s “A band of starved exiles” or something like that.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.