Purge not spawning on private gportal server

I rented a gportal server yesterday with the intention of getting lots of purges. No mods installed. The purge meter trigger value was set to 5000 with update intervals of 5. I got one purge and it was great, I was really hyped. A couple of hours later, my meter was full again - and then it got to the end bar - and then about 6 hours passed with the meter on the end bar and the purge never triggered again.

I read there is a ‘purges per day’ setting which is not in the serversettings.ini file by default. I found on the wiki this can be added by the line ‘purgeperiodicity’ and tried various values from 50 to 10 and reset the server several times.

I even reinstalled the server and created a fresh .ini file changing nothing but the purge meter fill value this time.

I tried leaving my clan, waiting with no clan, creating a new clan.

I emptied my purge bar and refilled it with the console. Nothing happened, so I tried to manually spawn a purge with the console.

None of the above had any effect, and I have yet to have a second purge. This is really sad and frustrating, because Conan Exiles could have been a true masterpiece of a game but is held back by developers who don’t know or care enough to communicate clearly how their server settings work and share that information with the people who really, really want to love their game.

I need some help (or some luck) or I’m sadly going to have to give up on Conan Exiles.

1 Like

could you post a screenshot of your settings and the location of your base? do you see in your event log entries for purge started / purge ended.


Hi @thephilosophyguy, as Narelle suggested we would need you to share your current settings for the purge, as well as the location and size of your base(s), in order to try and reproduce the issue on our end.

We are also aware of a few issues with the purge that are currently being looked into, so any additional data we can gather that might related to them is helpful.

As another player has mentioned on his thread, he had to build further in order to get his purges to spawn, so that also might be worth a shot:


Hi thanks for your responses, I’ll be able to get onto the game this evening. I’ll expand my base to the size you suggest and let you know if it spawns or not. If not, I’ll send screenshots of my server settings.

MinPurgeOnlinePlayers was definitely set to 1, and I will make sure to keep an eye on the event logs throughout.

1 Like

Set at 0 can give you offline purges.

Looks like the problem, whatever it was, has been solved. I had 3 purges today, great fast-paced action. In order to get here, I wiped the server - not very scientific, I know, but I was frustrated and wanted to try again starting from scratch. I did not, however, change anything in the serversettings.ini file between having the bar-full-but-no-purge issue and now. What I did change was building a new base in a new location. Having made a few observations about my own problems and the behaviour of NPCs during the purge I have formulated a theory of what was causing my issues and the one @Hugo mentioned above.

I believe purges are triggered by NPC aggression towards the structure at a particular co-ordinate. I think the governing factor is not the structure itself, but the co-ordinate, and that some sets of co-ordinates are simply not recognised by the purge. (As it happens, the first purge I had the other day destroyed part of my base, and though the re-build was roughly the same size, it was a hundred metres or so from the first location.)

On official servers I have had purges at 5x5 t1 shacks as well as 30x30 t3 fortresses, and I have read that people have had purges target lone foundation squares they placed around the map just to push the purge meter. This leads me to believe that the issue has little to do with the size or tier of the base (all 3 purges today targeted 100% t1 builds), but whether it intersects with a co-ordinate the purge is able to target. So perhaps this fellow Hugo quotes did not get purged because his base expanded, but because, via expansion, it finally managed to hit one of the purgable co-ordiantes.

This could also explain why I couldn’t get a purge even through console commands - it simply didn’t recognize my base as a valid location.

I’m not a developer and know next to nothing about coding, but I just wanted to share my theory in case there is something in it.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.