Purges Not Triggering

Hi all,

Trying to get back into the swing of things and started up a new server for myself and friends. I noticed in testing however that the purge doesn’t seem to trigger. I’ve tried everything at my disposal; StartPlayerPurge commands, slomo, etc., to no avail.

Using the same settings offline (and the same mods), I am able to get the purge to trigger without issue, but online just doesn’t want to cooperate.

Has anyone had experience with this that may be able to suggest a solution? Having the added survival element of Purges is one of the main selling points for my friends, so hoping I can get this up and running sooner rather than later!

May i ask, what is the event log saying when you start purge using command ? [in online mode of course]. When submitting the event log, please extend range to 2500, click it, and then make a new submit 4 min after the first one. I would be interested if it says purge started, and purge ended with nothing actually hapenning.

Also, what are your purge server settings, and have you created a clan [even though you are just with your buddies, clan creation reportedly have an effect on purges in single and multiplayer settings].

Event log isn’t displaying anything, unfortunately. I do know there are potential issues with trying to spawn in inaccessible areas; I’m testing in the same area as where I can trigger successful purges in SP, using just a cluster of foundations on level ground.

I am using a clan (and just recently tried it again with a complete vanilla install, removing all mod references from the DB, still to no avail).

Server settings for purge (testing, at least) are below:

PurgeLevel=6
PurgeDelay=5
RestrictPurgeTime=False
PurgeRestrictionWeekdayStart=1800
PurgeRestrictionWeekdayEnd=2200
PurgeRestrictionWeekendStart=1800
PurgeRestrictionWeekendEnd=2200
MinPurgeOnlinePlayers=1
ClanPurgeTrigger=2000
ClanScoreUpateFrequency=15
PurgeDuration=30
PurgePreparationTime=10
AllowBuilding=False
EnablePurge=True
PurgeNPCBuildingDamageMultiplier = (5.0, 5.0, 10.0, 15.0, 20.0, 25.0)

I have also tested with CanDamagePlayerOwnedStructures=False set to True, but still no luck. PvP/building damage timegates are both set to False.

It seems you know the stuff [few people do], i was betting on hidden foundation somewhere, but as you say when the events log doesnt show purge starting when using command, the issue might be in the command. Have you tried more natural way using these commands ? I mean when insta purge commands doesnt work, maybe these will trigger it in 15min time.
FillPlayerClanPurgeMeter
EmptyPlayerClanPurgeMeter
FillAllClanPurgeMeters
EmptyAllClanPurgeMeters

Honestly i am out of ideas, as all other ideas i had are not relevant when you already tried fresh reinstall [so buildings and other players doesnt screw the interaction on the server]

Edit. So i went through my saved google searches and topics, and the purge issues are indeed mostly on private servers, and in a way that commands doesnt work there, but should start when commands that fill in the meter are used.

Yeah, unfortunately I’ve tried everything I could think of; I’ve allowed the meters to build naturally (via slomo), tried StartPlayerPurge with and without specific waves defined, tried to forcibly push the purge meters via commands, nada.

I even tried switching host just in case that was an issue (initially on gportal), but still nothing. gportal support just points me to the wiki page that says purge functionality is a ‘known issue’, but that was last updated in august and I’ve seen plenty of comments in discord since referencing regular purges, or even too-frequent ones.

I’d assume if this was a widespread issue, someone would have come in here already and said “nope purges are borked”, but my guess is this is unique to me for some reason.

There is one more thing to do, invoke the name of power, @Ignasis [The lesser daemon of Funcom :wink: ] and wait for day or two.

That’s probably a helpful step I hadn’t thought of!

-lays out a circle of black-wicked candles for the summoning, and waits…-

Thanks for the help :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.