Riddle of Steel DLC Won't Load

Game mode: [Online | Singleplayer]
Problem: DLC
Region: U.S

[Free text]

Steps on how to reproduce issue:

  1. Launch the game
    2.Get prompted to purchase DLC that I already have

My wife and I co op Conan and all DLCs on two separate Xbox consoles. An original Xbox One, and a Xbox One S.

The original Xbox can not get Riddle of Steel to load, for the life of me, and I still get promoted to buy it, even though I have confirmed that I own it in the store. I have also tried uninstalling and reinstalling twice, with no success.

The One S on the other hand has it no problem. While yes, whoever is on the One S could just make the items, for the other(thought I’d just squelch that comment now). Its the principal of that I should get what I paid for. Any help would be greatly appreciated.

go to your games on xbox
go to conan and see if the dlc is instaled
i think that maybe thats the problem

It sure is. Tried that as well before I hopped on here. Went to the “Manage” section, and looked at all the add ons.Riddle of Steel is indeed in the Installed list with all the other DLCs that are running just fine.

However, when I play the game, it acts as though I never purchased it in the first place.

Might it have something to do with setting one (or both) of the Xbox’s to be the home Xbox?
Unless you bought the DLC twice, one for each profile, you need to have the profile that bought the DLC to be on an Xbox that is not the home Xbox, the other profile, the one that did not purchase the DLC, needs to be on the other Xbox with the profile that bought the DLC set as the home Xbox owner on that Xbox.

Hope that helps.


Hi @Andrecli, did you also try to reset the cache by holding the power button for about 10 seconds until the console powers off, then disconnecting it from the power outlet for a couple of minutes?

I do have the system “homed”, and also yes I did do the " cache reset". Thank you both for your replies.

In the end I uninstalled and reinstalled the game(entirely), and poof, Riddle of Steel loaded just fine.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.