Rough Timber Balcony missing from Sandstone Set 2

So, the piece that I was looking forward to using most, after paying for is missing. The Rough Timber Balcony is missing from the Sandstone Set 2 I just purchased. It’s clearly advertised as part of this set.

I love your game, Funcom, but Crom damn! :joy:


Greetings everybodyvsME!
Thank you for reporting the issue regarding the Rough Timber Balcony you just purchased.

Given our newest Bazaar Shop, make sure you take a look at this article, specifically the ‘‘Help section’’ below, where you may find a solution to find your Rough Timber Balcony :slightly_smiling_face:

If this article doesn’t provide the fix, please contact us through our Zendesk platform in order for our team to properly assist you, or in game following the option ‘‘Request Help’’ in the Main Menu.

Thank you for reaching out to us everybodyvsME and I hope the Balcony finds a good place in your base!

Yeah, you’re right. It seems to be completely missing from the set. Can’t build it and it doesn’t appear under the Ancestral Knowledge tab in the Rough Timber Frames section.

Yeah, I have the same issue on PC. Waited for 10 minutes, restarted game, and searched for it like Medraut did, but it does not appear as one of the timber frame pieces, even tho it is clearly being advertised along with the set :slight_smile:

Probably a bug, we’ll just have to wait for them to sort it out. At least the other pieces are neat too. But not as neat as a rough timber balcony…

Some feedback. Remove the Official Server Number. I had to type 0, as I’m unable to leave it blank and I do not play on officials.


1 Like

I have the same issue

Hi same issue on Xbox with missing lattice window. Tried to report this in-game on Xbox but that’s also an issue as it will only allow me to enter my email but will not allow further selection options in order to report.

@HighSaint, any feedback on this missing piece that both myself and others have paid for that we are unable to use?

I understand others are having issues with their gaming experience since the 3.0 update. However, I paid just about $9.75AUD for a pack which did not include a piece that it should have, over a week ago, yet have no response except that my original post should’ve been in a different format.

No disrespect, but how is this ‘customer support’?

1 Like

Seconded, I appreciate its balls to the wall at the moment but you are in iffy ground when it comes to advertising goods and then not providing them when purchased.

It seems to affect all versions too.

Just to note, it seems it has been corrected with the most recent patch.

This one is able to place and build such pieces now.

Has everyone who purchased the pack checked to see if the patch fixed it? If one is on a server they may need to wait for a server refresh before it works, but by now it should be good.

Yeah, it’s available to craft now after the latest patch.

Still crap customer support.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.