Several problems observed/experienced lately

pc

#1

Platform: PC
Game Mode Official Testlive
Problem: Bug

The following problems have been observed:

  1. Objects/buildings owned by a single person who is not a clan member still show up as “Unowned” to both the owning player and to all others (Click on object/building owned by a non-member to reproduce if such object displays ownership).
    Workaround (by players): Player creates a “clan” consisting of themselves. Ownership is automatically updated to the clan name. I believe there was a bug patch concerning this but I’m not sure how it was pushed out or if it has at all.

  2. Death markers not showing up (Intermittent issue. Difficult/impossible to identify the steps to reproduce). I suspect that this is happening because the player’s “body” has fallen through the map or similar malfunction. As a consequence the returned player cannot ever come into the display range of the corpse to trigger the marker generation.
    Workaround (by the developers): Always show the player death markers at the point the player “died” and not at the location the body is supposed to be. Do not disable display of the markers based on the player distance from that point (always on). A more permanent solution is correcting the issues that cause the body to “disappear” in the first place.

  3. Floating plants. Several areas. No steps to reproduce. Simple observation only. The plants in question don’t have a collision box active around them and aren’t subject to player interaction. Most notable in the central desert region where the birds are centered. No obvious workarounds other than making sure that every object spawns with gravity and any overlap avoidance setting prevents a vertical displacement.

  4. Animals running away into the air. Fleeing animals seem to have the ability to fly! I suspect the same code is used from Epic’s Boy With Kite demo which has the same problem (I’m a senior developer with another independent producer using the same, though later version, game engine and I use that package to test performance of any build machine I put together). No known workaround. I guess the question can be asked on UDN but I’ve never gotten around to it.


#2

Devs are aware of it. A tentative fix is on Testlive.

An update to death markers is on Testlive, so here’s to hoping that fixes the issue.

These aren’t exactly game breakers, so I doubt we’ll see work on these until after launch. I always thought the flying animals was a sync issue, though.


#3

I have noticed something too.

Platform: PC
Game mode: Private live
Problem: Bug | Misc
Revision: 94750/17645

  1. Using a skinning knife right after a animal is killed doesn’t give anything, like I’m not hitting it. Same with a cleaver. Using it a second time works.
  2. Sometimes when over encumbered and out of stamina it is not getting grayed like it usually is when you run out of stamina.
  3. Some resources like trees and brimstone will disappears after one hit. Trees disappears around The Sandpit.
    Brimstone is being destroyed in one hit around Shattered Springs but if I continue to hack on it I get resources.
  4. When over encumbered, the on-screen text shouldn’t be spamming all the time. Maybe 3 times and then blinking icon under the health bar. Now it constantly blinks when you have too much with you and it doesn’t end when under 100%, takes some time.
  5. Thralls, mostly fighters, spawn in large numbers after being killed in New Asagarth. Think server restart is helping with this but after killing them a few times they start to group up. It looks like there is only one fighter thrall, but when he moves there is more of them.

#4

Confirmed. This has happened to me, too on Official #403.

Resources are bugged currently near the border between the desert and the Swungle. This was reported in one of the latest patch notes, so the devs are obviously aware of this.

I’ve notice this as well. You hit one, it splits into two. It’s like fighting the Multiple Man. Same with the wights in “Mounds of the Dead”, too. You hit one, it splits into teo


#5

Flying animals on a local project are definitely not a sync issue. :stuck_out_tongue:

As for the flying plants (and rocks) I was just messing with Landscape Auto Materials today on a quick map project (Unreal 4.19.2) for a demo and after carving out a spot in the landscape to put in a body of water I tried to paint it to remove the grass and boulders (gosh those looked familiar! :wink: ) to make space for a small community. I’m not sure what happened but after everything rebuilt I had a HUGE mass of loose plants and boulders floating up above my lake bed. I tried deleting the layers and even the instance of the material from the landscape actor to clear up the problem. Naturally as soon as I put the material back on the actor… surprise! I’m figuring I’ll just delete the tile and make a new one. The whole project is just supposed to be a quick thing for PR videos so I’m not planning on committing a great deal of time on it. I wasn’t thrilled about taking time from main production with our first release coming up but we are short of people who have the skills and equipment to produce such things. I’m still taking the 8th off for your release. (I’ll be on official server 401). Congratulations! I’ve been trying to provide informal support to your players since I started with this game - time permitting - and I hope to do more of it in the future.

Richard Robertson, Sr. Developer, Projects Manager, Co-founder, Missing Worlds Media, Inc.


#6