Shrines Disappearing When Upgraded

Game mode: Online official
Type of issue: Bug
Server type: PvE - 1508 PvE-g-portal us
Region: US

I had this happen twice now. First time I tried to upgrade a Shrine of Derketo from Level I to Level II. I placed all the proper upgrade materials in the shrine and the "cooking timer icon - (i don’t know what it is called) started. When I returned 5 minutes later the entire shrine disappeared and all that was left was a large loot bag in it’s place. I could not access the loot bag.

The 2nd time this happened was incredibly frustrating as i wasted a large amount of high level material. Same issue happened when I tried upgrading a level II Shrine of Mitra to a Level III shrine. Same process, added all the proper materials to the shrine, clicked on the upgrade icon. Left for about 5 minutes and when I returned, the entire shrine disappeared. No loot bag no nothing, just empty space.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Build Lvl I shrine of Derketo or Lvl II Shrine of Mitra
  2. Add materials to Shrine to upgrade it to the next level
  3. Click upgrade icon
  4. Return a few minutes later to missing shrine

Known issue across all platforms. =(

Being looked into. =D (not sure if eta on fix yet thou)


Happens all over our server server too

Happened to me too on server 3879 PS4. Upgraded a set altar to final form with 1500 zeal and a named arch priest on it… and poof! gone.

Can I assume upgrading the Set altar to final form will also fail on a private (not solo) server?

If so, I can be very patient, even if there is only a chance.



This doesn’t just happen with Mitra and Derketo, i’ve had it happen to Set and most recently Ymir when upgrading to Tier 3 even if there’s room for expansion. At this point it feels like it’s just pure luck if you DON’T lose your zeals, material and arch priests when you upgrade.

Thank you, Ahris. From this, I think I will wait. I really just wanted the beam of light anyway :wink:

Already getting the snake arrows, which was the main purpose of the altar.



Just happened on Official server 1709 also while upgrading from 2 to 3 with Mitra shrine :frowning:

1 Like

Has anyone heard if funcom plans to address this?

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.