Siptah - Thralls from Cages

Since the Age of War 3 Update there seems to be a problem on Siptah with the Thralls you can get from the cages in the camps.

  • Game mode: Private rented Server
  • Game type: PvE
  • Detailed information of the occurrence:

Get a key from the prison guard and then open the cage with a thrall in it. Previously the thrall would now follow you and you could give him instructions or so. Now those thralls walk out of the cage and just roam around. You can not interact with them. The only thing you can do is kill them.

Dont know if this behavior is now the way it should be but I think it was better before. You saved them from the cage and they are so thankful that they work for you from now on.


No one else has this problem?

I haven’t done one on siptah yet, but on EL it’s definitely not like that. I can’t say for certain if it’s an isolated issue for you, but this was definitely present in the Chapter 2 test server and was resolved prior to its release. I plan on doing a purge base at some point in the next month or two probably, but currently, I can’t corroborate your issue. Sorry!

Oh, btw, I’m on PlayStation, so even if I got it to work, that doesn’t mean it’s not a PC-only issue.

Yes, same thing happening on Official Siptah server, caged thralls upon release stay red, no message that you rescued a thrall, just have to kill them

You can hit them with a truncheon, and drag them to a wheel or gibbet.

that should be true as well, have not tried cause they were trash thralls, however the mechanic still has changed, was it intentional or not?

Noticed this issue as well on Siptah. IMO the mechanic is broken.

No, it’s not intentional behavior.

I play on Siptah and have not encountered this issue. Do you already have a thrall following you when this happens? If so, it’s normal for the ones in cages to step out and roam a bit around the camp until you instruct them otherwise. If not, then the first one you release should follow and the rest step out and roam/dance.

He stated that they can be killed, so that’s unlikely. They don’t follow you, but you can still break bonds. By the sound of what he’s saying, they’re not linked to his clan or player. You can’t kill your own thralls… by standard melee means that is…

It worked with a T3 archer, who could be useful up front, with trained named archers in the back.

yes, T3’s or lower can be useful as pawns, esp if you are new or have not yet had the opportunity build your thrall army

No, I have no follower with me, no human and also no pet. I even can not interact with them - I can not open their inventory, can not give them instructions. Nothing.

noticed this on Official Siptah server as well. Heretic Haunt in O13 has 3 cages which have always been randon. usually one cage has a thrall in it, but now all 3 cages always have a thrall in them, and upon release they do not automatically become your thrall. you can kill them or knock them out and drag to a wheel.

Greetings Exiles,

Thank you for sharing this!

We’ve forward it to the development team so they can investigate.

1 Like

Also having this problem. Whether they can be tamed by conventional means doesn’t matter. I have validated all my files. No change. Not much left to do but see if it can be fixed in a week or so. Past experience says no.

having this problem as well, any workaround or temp fix?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.