Sorcery progress unable to continue

Platform: PC
Issue Type: Sorcery Progression Bug
Game Mode: PVE
Server Type: Unofficial
Map: Exiled Lands
Server Name: Sanctuary of the Gods 18+ PVE 4x/AOC/EEWA/3
Mods: Quite a few, but none that directly effect Sorcery as far as I’m aware.

While progressing through learning Sorcery I ran into an issue on the 9th level of Sorcery, the level that costs Tome of Kurak, Sorcerous Spell Page, 10x Demon Blood, 10x Grey Lotus Powder and is supposed to teach Mirror Mark, Invisibility Self, and Conceal Corruption. When activating the upgrade instead of learning the three expected spells I learn the Transportory Stone. After the animation completes the tome upgrade recipe is unchanged, and using it again just re-teaches the Transportory Stone.
I have tried removing my Thrall from the Table and redoing the upgrade, as well as making a new Table.

Try to replicate that in single-player.
If you get the same there, remove all your mods and try again. If this time you don’t get the issue then it will be one of the mods affecting it, which you can find out pretty fast by disabling half of them every time till you find the culprit.


I tried with two fresh characters on a single player game to reproduce this issue, one at level 10 and one at level 60 with a Thrall in the Table, and both were capable of learning all the way through the 9th and 10th levels of Sorcery just fine and did not learn the Transportory Stone early like I did on the server.

Is there anything an Admin on the server could do to potentially push me past this issue?
It almost seems like it believes I have completed the Sorcery knowledge line, since it keeps giving me the final level’s stuff each time I try to perform the Tome Upgrade action.

I did also test two other things:
I tried giving one of the two test characters the Feat for the next tome and took away the current. That character was on the 10th level Tome Upgrade (Elixir of Rebirth) and using the 11th level recipe (Book, Page, Demon Blood, Sacrificial Blood) resulted in getting the knowledge from the 10th level.
I tried giving one of the characters the Transportory Stone word of power feat, and they were still capable of learning the 11th level that they were on.

That seems like a very specific glitch.
Any chance you used a yellow lotus potion btw? That can have an effect on sorcery since it’s bugged atm, though its typical effect is to unlearn your main sorcery perk and not allow you to progress that way, this variation I haven’t seen.
Have you also tested whether this is purely visual? As in, if you progress all the way and unlock all spells despite getting the Transportory stone message for all unlucks, have you checked whether you have the actual spell runes when using a staff etc.

As for what an admin could to on that server is to either try and reset your progression by making your character unlearn all recipes associated with the feat and then you could go to the cave again and start over. Or they could manually teach you the feats - even insert them directly into the database.

Still I wonder how you ended up with this though :thinking:

I did not use a Yellow Lotus potion.
Though, I also had the thought after posting that the Paragon Levelling mod (Levels to 300) may have messed with it. So I set my level to 150 and tried again with the same result.

And yes, this issue seems to be that I don’t gain any new words of power or recipes. Like I skipped form completing level 8 to 15 without earning levels 9 through 14. I also am not getting the next Tome recipe and cannot craft the Elixir of Rebirth. I do not see the runes for the level I tried to learn when using a staff either.
Here is a screenshot of my Sorcery section of Knowledge on this character:

So, for an Admin to reset me they just remove all my Sorcery knowledge feats including Basic Sorcery then I go back to the cave to relearn it. Right?
After that would it be expected that I can progress through the tree again from the beginning?

I would love to know too, no one else seems to be having this issue from what I have heard. At least, no one else has mentioned it on the server. Several others have references being able to use things from after the point I’m stuck at as well, some of which seem to have learned it after I got stuck.

That’s weird, even your screenshot looks to be in order.
Yea they would have to remove all of the feats though so you don’t have any messed up data in there, so all feats that are a child of the sorcery one and then the sorcery one as well.

(What would probably help Funcom diagnose this is if you could somehow include a copy of the database in this report, maybe the server owner can send it your way or something if it’s not too large)

Alright, so I took a bit of a look at it, I have a fix for you, though it requires the cooperation of your server admin :slight_smile:
Tome of kurak progress is saved separately in the database so unlearning the feats alone won’t reset that, the progress also needs to be deleted

So your admin needs to:

  1. Take this script and copy it to notepad
@echo off

set char_name="Xevyr"
set db_file="game.db"

if NOT exist %db_file% (
	echo No game.db file in this directory!

echo Deleting sorcery progress for %char_name%...
sqlite3.exe %db_file% "delete from properties where name='BasePlayerChar_C.SorceryGrimoireProgress' and object_id in (select id from characters where char_name like '%char_name%')"
echo Complete!..
  1. Replace the name on the top where it says Xevyr (I used my character name as an example) with YOUR exact character name (if it’s a Siptah server they need to change the database name as well to the Siptah one)
  2. Save the file (select all files instead of text documents) as a batch file, example: SorceryReset.bat next to the database files where the sqlite3.exe file is also located
  3. Take the server offline for a moment and execute the file

This will wipe your sorcery progress, after this you’ll have to go to the cave and use the book again to relearn it, then progress through it normally.
If your feats weren’t removed one by one before this I think it should still be fine as you will learn them again, which will simply overwrite them again and won’t cause duplicate spells - at least I think so.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.