South american servers having problems since morning

Some players (me included) are not being able to even see the official SA servers on the server list. I can see NA no problem tho.
I also have friends that can see (and connect to) them.
The problem is that, from those i know are having this issue, not everyone has the same internet provider (otherwise it would be very likely a provider’s end issue).
It’s been like this since today’s morning. Reestarting game, steam, pc, internet, verifying files and even reinstalling the game didn’t help. Manually connecting to ip doesn’t work either.

Any ideas?

4 Likes

Estou com o mesmo problema, achei que fosse algo com minha internet mas pelo jeito não é, já que outros estão tento o mesmo problema.

3 Likes

up

1 Like

24 hours with this problem and no solution!!

up

1 Like

Since yesterday!
i’ve tried all those things too.

1 Like

I have the problems that tbm on ps4 enters any server in America and private, when you enter the server in Latin America and so it was not possible to connect to the server. Your connection to the organizer has been lost

1 Like

up

estou com esse problema tamém, inclusive já até falei com o RenanObarbosa, e ainda não consegui solução, tá osso, perder todo o progresso, quase 70h jogadas no lixo, não da pra ficar assim.

1 Like

70 hours only i have 3 thousand hours in conan and i can’t get into latin america servers

1 Like

up

Still no sollution after more than 2 days. I’ve also contacted support directly and i haven’t had any responses.
I managed to connect to the server i play on by installing a VPN, but it’s only a 3 day free trial so soon enough i’ll have the problem again.
Can anyone fix this (■■■■■■)?

Obs.: quem estiver com o problema, baixa um vpn que funciona pelo menos até arrumarem. Eu to usando o exitlag, tem 3 dias gratis.

@Ignasis @Hugo, at least freeze decay timmers… Too many reports , incoming with unussual speed from South America… let players keep their bases!!!

1 Like

up

Oh my God, has anyone found a fix for this? My vpn free trial is over and the problem persists, and I won’t pay for a vpn just for Conan, all other games work fine.
I’ve also reported on the “server issue report page” last week and haven’t received any replies yet!