Steam Deck / Proton Crashing Since Update

I’ve been running Conan Exiles on a private server (with Battle Eye turned off) on my Steam Deck for about a month. I had to force compatibility with Proton version 6.3-8 to get the game to boot on the deck. Other than the occasional crash, I haven’t had issues until today.

After the Conan update I unsubbed from all workshop items, updated my deck, updated Proton, validated the game files, and rebooted several times but I keep crashing at the menu / server select screen. Has anyone else had this issue and found a solution?

Bumping for visibility.

My partner has this exact issue since yesterdays update. She did everything you did, as well as trying launching from desktop mode and turning off proton compatibility, and no luck.

1 Like

I also tried doing a fresh install of the game and that didn’t work either. I’ll keep experimenting and post here if I figure out a solution.


After A LOT of troubleshooting I magaged to find a workaround. I’m not sure what did it in the end so I’m posting everything I did leading up to a full launch of my private server:

  1. Uninstalled the game.
  2. Used desktop mode to go into the file explorer (Dolphin) to search and delete any straggling Conan files (there were a few).
  3. Reinstalled the game.
  4. Disabled force compatibility.
    4.a Used launch configurations in the properties of the game in steam to launch the game in safe mode. (Properties > General > Launch Options and enter -safe in the dialog box)
    4.b Unsubbed from all mods in the workshop.
  5. Launched the game in Desktop mode.
    5.a Disabled Battle Eye from the launcher (in Desktop mode).
    5.b Fresh launched the game using the LAUNCH button.
  6. Used direct connect to re-enter my ip etc for the private server from the server list. When I didn’t crash at the server list, I was optimistic I had fixed the problem.
  7. Let the server reinstall my mods and relaunch the game.
    7.a I crashed at this relaunch step but I usually do on the Deck so I just rebooted the game and it joined my server.
  8. After fully loading in to my server I fixed my resolution / graphics in settings.

I was still not able to successfully launch the game in gaming mode on the deck - only desktop mode. My hypothesis is the latest update made the game even less Steam Deck compatible than it was before.

1 Like

Awesome! We will try this later tonight and let you know if this works for us as well!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.