Still no connection to TSWL through steam account

I’ve read some 5 hours ago that someone will fix it, and actually there is still no connection to the game. Can you inform us about this problem?

Issue is with Steam/Valve, so someone at Funcom can’t fix it. Some people make it work by using different methods (look in thread I linked).

1 Like

so far I can’t make the game run. steam can’t authenticate my characters; tells me that I need to fix my firewall or my connection: but it is only SWL affected here. So I guess I need to find a new game…

Firewall is set for each software : they are not ‘global’ settings. Whether is works automatically for most of your games is not an argument. A recent patch may have changed the SWL clients.

On Steam, Andy B (Community Manager) wrote :

  1. Clear your Steam download cache
  2. Spam the login button (?)
  3. Make sure your Firewall is set to allow Steam and SWL through

What I did first :

  • added the two SWL clients (.exe) in the Firewall exceptions ;
  • did Repair broken data (launcher option)

The client auto-closed silently when I clicked Start (following the Repair option).
Re-launched launcher.
A patch (348 MB) started to download.
Result : nope, could still not log-in.

  • Then I flushed the Steam download cache (Steam Settings > Downloads…).
    (Steam will close and require to relog)

Result : as I post this, it still fails to authenticate on Steam again.

What did work :

I read on the forums of people who got in by cancelling the authentication (when character(s) should load) and re-trying many times.

It took about 15 attempts, waiting about 5 seconds each.

i eventually got in by uninstalling and reinstalling the game.