Stuck at end of mission "last train to Cairo"

Hello,

I am stuck at the end of the mission “Last train to Cairo”. After defeating the boss, I am unable to either break the glass ceiling of the train car or detach the two cars.
I tried this four times :

  • Twice with friends, who succefuly ended the quests but not me. They broke the ceiling and detached the train, I could follow them, I had the final cutscene, but when returning to the main map I was stuck at tier 2/2.
  • Twice alone, I couldn’t even break the glass ceiling.

Could you have a look ? I posted petition but did not get any answer in ~6 weeks.
Thanks !

1 Like

Hi, @nameofagod - Sorry to hear you’re stuck. I haven’t played through that mission in a while, but as I recall, you can highlight both the glass ceiling and the hitch (if that’s the right word) to the car. Maybe try fiddling with your target crosshairs to make them bigger (or visible) to see if that helps?

Hi Blodwedd thanks,
I tried interacting with the hitch and the ceiling but, no matter how long I fiddle, move, zoom, log in an out… I just cannot interact, it never goes red.

I’m sorry to hear that. Hopefully, someone else will have a suggestion that might help you.