Stuck in horse, this is trash 🤦🏻‍♂️

Game mode: [Online | Pve official
Problem: got off my horse facing away from cliff and ended up inside my horse

This is rubbish. Video speaks for itself. Rhinos, dragons and now horses. Surely it’s not that hard to get you’re collision detection stuff working better than this. I’ve got no option than either ripping my bracelet and trying to get back in time from the other side of the map before my stuff despawns or breaking bond and losing my horse and whatever he is carrying. You’ve got time to make a whole new map but the basic mechanics of the main game are still not right after several years. Not cool.

Steps on how to reproduce issue:


I agree that this must be very annoying for pve. You could try if you can manage to place a bedroll a bit away from the horse. By looking at the video it would have most likely been possible. Then you could have removed your bracelet and grabbed your stuff again.


I agree getting stuck in a horse or a thrall should not be happening still. One option might have been to have your horse stop following perhaps it might have wandered off. Probably not though it seems to be stuck on you. :smirk:


It would have wandered off eventually but depending on your luck it might be 5 minutes that you’re waiting or 3 hours

1 Like

Any follower should understand that you want to move through them and let you pass :^)

I see you can access the radial menu for the mount when that happens. Just out of curiosity, what happens if you select “mount” from the radial menu?

On PC it helps me get out of that situation, because it allows me to mount the horse, although after several long seconds, while the game tries (unsuccessfully) to figure out a path for my character to walk to the horse. Does that also work on PS4?

1 Like

I tried numerous times to mount and it wouldn’t happen for me. I ended up just ripping my bracelet and my horse found his own way back anyway. It’s just so frustrating trying to play this game sometimes. When everything is going well it’s one of the best games I’ve ever played. When it’s having one of its meltdowns (which seems to happen more the longer you play) it’s just plain horrible lol :joy:


Why does Almost every aspect of playing Conan exiles require players to have a work around? They either can’t fix it or won’t.


Yes it does, however there will be problems if you are stuck in a tight area because the game will tell you that you can’t mount here.

One good workaround for that is to equip a weapon after you pressed the mount button. Works in 4 out of 5 cases. I have only tried it with spears though


Hi @Darkzombie, the issue is known and being looked into by the developers, apologies for the frustration caused. We’ll be sure to relay the video and feedback provided.


My thrall gets stuck in my horse and also the thralls over the last 3 days in training are not showing a change in the HP bar. They go up 7 levels, get the stats for Strength, Agility etc but stay the same HP for 7 levels?
Now you have strong thralls trying to kill lv 1 cooks in the city and get heavily beat up with 25 swings before killing them?
Somethings not right. Im on private server, PVE, PS4 side and since the patch each day has gotten worse. I cant train with good stats and a 1217 health bar at lv 11. It doesnt make sense.


@Cmespeedn99 what thralls are you starting out with? The named one’s along newbies river started with more than that. I have a private server and play on a couple more. I don’t know of a setting on Gportal that could change thralls health levels. Check with others on the server to see if they have the same issue. Might also contact the server owner. Good Luck

1 Like

Between a MESA and my BEAR.I had the same issue a few days ago, in the city, where thralls and bedrolls NOT ALLOWED! I signed in and out 6 times as well-Finally Bracelet removal Dead Bear and loss of gear. Just sucks -again.


Honestly, i found jumping gets me out of horse. Mine likes to creep up on small inclines to be inside me…

Other work around is clickng horse and waiting a few seconds (about amount of animantion playing) you’ll hop on it.

Rhinos tend piss me off, as me on horse get stuck inside till it does push attack or a get horse to jump. -_-’

elephants do it to…but thats ussally just gets me killed, so can rarely make horse jump in time. XD

1 Like

Something tottaly out of clue. You were in jungle on this video, i understand it from the music :wink:.

siempre sucede , en ps4 es normal que suceda

Im a lv 60 training Dalinsia or Teimos. Had em before the patch and training new ones. I have a notebook to keep stats. Horses stuck at different times a total of 11 levels.
Thralls…Fighters getting stuck and many negative same stats. Skullker, Angry Drunk, Archer perks when its not even an archer im training.

1 Like

Another option, log out for 15 min plus, your horse should return to the spot where u told it to guard like it did when it took you killed yourself and returned to get your stuff.

Many people have been complaining about thralls following too close for a long time without getting fixed. I would put this problem in the same category and thralls still are following too close without any end in sight. In most cases you can jump out of them now which is good but the problem doesn’t seem to have much thought put into it so these kind of problems don’t happen.

Yes Anna the Crusher picked up archer’s perk going to finish her. 2 hand Sword and a Bow see how it works.

I had a super funny experience just yesterday. I was in the brimstone lake area. I dismounted which can always be risky if the ground is not flat. I ended up under the horse, but actually had my head stuck in the belly. Now when I moved it looked like I was a horse. I could not get out and using a weapon damaged my mount. I did not mess with it too long and removed my bracelet as I was close to home. But it was pretty funny to see. I should have vide’d it really, sorry I did not.