Testlive Patch (21.12.2018) - Purge Fixes and Building Optimizations

Combat-test pve 3 eu.
Archers doesn’t change weapons In melee in close combat.
After login you stucking on some flats (can’t climb, jump over, stuck the stones) rollover helps, fixin after several relogin.
Stunned hyena betwen N’batu’s pack and waterhole outlook.

I think I know what the problem is with picking up the baby pets. I’ve noticed 3 things that seem very related:

  1. baby pets often can’t be picked up
  2. trying to butcher corpses (or harvest bodies of NPCs) doesn’t work, even though you see blood splattering, until you move away and come back.
  3. once in a while, while walking or running, my position warps me to a position very close to where it appeared I was. Not the same thing as rubberbanding I don’t think, but maybe it is?

So my conclusion is that we are NOT where we think we are. Somehow we are getting out of sync. When it looks like we are picking up babies or harvesting, we are in fact aiming at the wrong spot.

I went back and check my map. I had not noticed that all of mine are also stacked in the center of the map. The newest one is on top of the older markers.

Interesting little visual bug.

Easy to reproduce. Not real sure how to clear it.

  1. Fill the quick bar.
  2. Open your inventory.
  3. transfer the unwanted items to your inventory.
  4. They will remain highlighted.
  5. Return to play and they stay highlighted.
  6. Clicking on them or selecting the number for the quick bar does not clear the highlight.

I did find that the Admin teleport does clear this issue.

1 Like

Guys, Jhebbal Sag attacks still goes through God bubbles, why is this still a thing? Clans are using this to raid on official servers, fix this asap please FC, people spend hours building towers with bubbles all in vain.


Since I started a new game to notice the progression, it’s refreshing to see Darfari are a little more challanging now.

Had no more freezes that needed task manager to close the game, I isolated it to the driver option AMD Radeon applied when I upgraded driver yeasterday.

It kind of reminds me of the time I manged to trace a lag spikes in my games and PC loading time to a program (which is thankfully gone now) that was using a lot of processing power (a little to much to the point of overkill in my opinion). Though how well to the Darfari use the combos in your opinion?

I reported it too, but then found it in the Known Bugs list :slight_smile:

1 Like

I am having the same problem as well on Testlive US3_PVE. Started building a new base by New Asagarth. Got the base foundations down and stairwell up to it. Logged out for a few hours and just returned and it is not showing all of the stairwell. If I tried to go up it i get stuck in the air so it kind of knows it is there, but not really. Tried running away but no luck, guess I need to run farther away.

Like its on the patch notes, the II and III use it better and fighters also block with shields again!
The damage variation on the spear attacks is noticeable also.

That is great to hear they are blocking with their shields again as most of my thralls have shields (I kind of wanted to make sure to aren`t sitting ducks in combat).

1 Like

Same here. I could not destroy the existing “ghost” building pieces.

I decided to start over to test the balanced leveling with crafting. I am back to level 28.

I do seem to have some attacks pass through foes without doing any damage.

That caught me off-guard when fighting in Sepermeru. I am glad it is back, but I was caught being lax in my combat tactics. LOL

OK, got some screen shots of the strangeness happening on Testlive_US3_PVE. As I mentioned in my previous post, I started a new build by New Asagarth. I got the foundations in place and one high wall going around, with this stairwell going up the side.

Logged back in and the stairwell is mostly missing, and you can see the standing torch is floating in the air where a foundation should be. if i walk there I rubberband around.

So i ran far away, in the hopes it would force a refresh and then it got worse.


Most all of the walls are gone, but not really since you cannot pass through the open spaces. visually they have fallen down to the lowest point on the foundations, and some have shifted all over the place.

Set my view distance to low, ran farther away and killed a bunch of stuff for a while and then went back and it was still the same.

I am mostly playing in the grimness of the volcano, since the lag spike issue bothers me a little less there. COuple things worth mentioning:

  1. I was able to drag a thrall from inside the forge area, to the normal surface and put in my wheel. Not sure if all portals are now accepting chained thralls, so I check some other cave portals and report later.

  2. When knocking out thralls in the volcano (maybe everywhere?), if on a non-player created structure, I frequently end up clubbing them through the floor, so I can’t bind them. Usually if I run away a draw distance and come back, they will reappear for me to bind. EDIT: Knocked a Jeb priest on desert sands and he dropped into the sand and vanished.

3a. PLEASE put some AI in thralls and pets to avoid the lava. There is no way to position a thrall outside a wall, for the purpose of protecting a wall as it is now. Scorpion was agro on me and I watched all my external thralls (mostly named) just run straight into the lava, even after the scorp was already dead.

3b. Also, the creatures that spawn in the volcano should be smart enough not to run into lave either.


I think this is not from this patch, can someone confirm but I’m experiencing it now:
Exiles faction now has II, III and even named thralls spawn on south river area.
This is great to get some starter crafters to reduce cost and time.

You’re right, they’ve been in since around the Halloween patch.

Things I’ve noticed so far:

  • when you move things from your inventory to a work-station, or inside your inventory, the yellow boxes which were around your items remain; not a big issue, since the boxes vanish after closing and re-opening the window, but annoying anyway
  • my newly built iron hatchet seems to harvest less ressources from the bodies of slain animals than I received when using my stone hatchet; this can’t be correct, can it? Furthermore, I would also second the proposition to add more bone to the loot, because they’re useful in the beginning to build arrows.

In general it looks good, everything works properly, I like the new stack sizes! Maybe coal-mining is now too easy, getting coal was always kind of a challenge before, now it isn’t anymore.

Additional: played a bit more and encountered some bugs:

  • when picking up baby animals they don’t disappear from the screen, though they appear in your inventory.
  • sometimes enemies kind of sink into the ground when knocked down by the final swing of a heavy combo; this especially seems to be the case with archers; they also look kind of weird when standing up from the knockdown, as if they were doing push-ups.

Also noticed some more things which work alright and which I like:

  • it seems that higher-level enemies are really better fighters now.
  • higher-level enemies, especially named ones, now seem to leave better loot.

More strangeness going on with pre-existing structures. My main base on Testlive_US3_PVE was there before the new patch went live, and it seemed OK for the first couple days after the patch but today after I went to the New Asagarth and back, it is now all messed up. Foundations have shifted all over the place. screen shots attached.

Some of these were under the altar, but have moved.

All of these foundations from under the Treb have moved.

I don’t know if this is due to the building optimization stuff or a combination effect of that and the testlive server up and running for 3 days.

Either way, hopefully the dev’s can get this sorted out.

Most thralls still only use their first combo step then wait then repeat. They almost never do any creative combos or complete either the heavy or light chain.

Edit: Reproduce: Give Lian a hammer or daggers and make him fight something. He will use the first heavy swing, wait, first heavy swing, wait, fight heavyswing. Maybe Lian is hardcoded for 1 handed weapons because he does more creative chains with sword and shield etc