The new thrall behavior wheel!

Sorry if this allready has come up somewhere. I did a search but found only old posts so…

I’m trying to set up a defended wall with archers only. And I want the archers to stand put and fire theire arrows. I tried all kinds of combos on the behavior wheel, but they only chase after the target, or sometimes even ignore the enemy all together and just stand there like idiots.

So I’m wondering, since clearly I do something wrong here, how should I set up the behavior to get it to work as I want it to?

3 Likes

I cannot figure this out either. My archers teleport off of their perches, or run into melee range before taking out their bow and backing up.

At the moment, purges teleport inside of yer base, so you may want to have fighters as guards.

3 Likes

An Archer that you want stationary should be set like this.

Attack range 50
Prioritize Ranged
Stand and Defend < this is the key setting to have them stand in place.

Here’s a video explaining thrall settings.

1 Like

Sorry, @Wak4863 but your video DOES NOT answer OP´s question.
Since he wants

all info in your vid (only concerning placement in relation to horizontal distances)
as well as what you posted will not help.

The problem is that at the moment there is no way to have archers in an unreachable spot actually defending without them teleporting. This has been thoroughly tested by lots of forum members.
I made a request and collected the links to the relevant community threads here:

2 Likes

Your proposed settings to combine:

do not work by default, because “stand and defend” and “prioritize melee” are two options from the same selection wheel. This means that you can always only chose one of the two at the same time. The relevant selection wheel offers these three options to chose from, and you can only chose ONE :

right?

Well stand and defend and prioritize melee certainly wouldn’t be good for archers in a raised position. I’m guessing it’s a typo. I have tested on the current live version of the game archers on a wall. Both set to 50 attack range and prioritize ranged, one set to stand and defend while the other is set to whatever the default setting is for a newly placed thrall.

The stand and defend thrall still backs up and move around about a foundation distance while shooting. But for the most part stays put.

The other thrall walks all over the wall trying to get a good angle or follow me around.

I made a foundation wall one and a half foundations high, so one half way out of the ground and another on top of it 2 deep. With a wall behind the archers and crenelations in front of them. I also place an archer on a pillar as stated in the other posts and was able to set him to both teleport down to the ground and to set him to stay on top of the pillar. with yes the settings that I described above and in the video. Additionally I set one on the ground and was able to run circle around him without him moving.

The settings must be done in the right order to get them not to teleport down, Engagement = Attack distance of 50 meters, Tactics = Stand and Defend, Prioritize Ranged. It’s important that the Tactics settings be done in that order, if done in the opposite order then they will teleport. You certainly can choose 2 options from the tactics wheel just not two opposing options.

Now it’s possible that they sorted this out in one of the hotfixes since the patch and just didn’t mention it or that the settings just weren’t done in the right order from the beginning.

Try it out and let me know if you are still seeing something different.

3 Likes

I tested your proposal in the setup you can see in the picture below. As pointed out in the linked topics, most of the teleporting occurres when the line of sight to the target is broken. That´s probably the reason why it did not happen to you (as is obvious from looking at your picture).

I tested every setting several times to eliminate mistakes (PC official PVP during raid times, patch 07.05.2020, hotfix 08.05.2020 and 13.05.2020).

  • The archer on a pillar tower (1x2) did teleport to the ground every time the rhino approached.
    Since the rhino arrived from the left, line of sight was already broken from the start.

  • The archer on a fondation tower (1x2) did not teleport to the ground.
    When I changed the options and only selected “stand and defend” at last it definitively sufficed. (same outcome)

This is remarkable because suddenly something works that did not before? It means either that all of the persons testing before in these threads: archers-behaviour-settings-bug and thralls-walking-through-walls-and-doors-and-being-killed did it wrong or funcom hotfixed some of the mechanisms without mentioning it…

(Well, thank you very much FC then ^^)

I still disagree with you about what you say about the “tactics”-wheel. It is not only because you are contradicting yourself in your two threads:

but my testing prooves you wrong: When I set my archer to both “stand and defend” and “prioritize ranged” in the order that you proposed, it runs after a rhino that returns to its spawn (the rhino obeying it´s new anti-cheese-mechanics). I think that is evidence enough that the “prioritize ranged”-option is over-writing the other one?

1 Like

Are you kidding me? If this is the case, then why in the world did the UI designer present these in such a way as to suggest they are mutually exclusive options in the interface?! This is completely counter-intuitive if correct!

EDIT: Well, just tried setting the archers in my Scorpion King kill pit to Stand and Defend, followed by Prioritize Ranged, and they are still teleporting to the ground. Not to mention, when they get singled out and attacked, they back up into the next postal code…


2 Likes

I suggest to set them to stand and defend again - and maybe try squares…
In my testing today archers teleported to the ground when on pillars or wedge ceiling tiles, while they stayed on the square ceiling tiles with the above settings. I even tried with another character, not in the clan (when raiding time on PVP) and tried to hide and walk away to break the line of sight, but they stayed on top… Here´s the building with triangles and squares layouts:

1 Like

I’ll give it a shot and see what shakes loose, thanks.

1 Like

I now tried and used “Stand and defend” and set the chase distance to 5 meters and the attack distance to 50 meters, plus “Prioritize ranged”. I did it in no specific order and now it works, sometimes. The best I can hope for right now I guess. :slight_smile:

Thank you all that replied to this thread, keep up the good work with testing around and hopefully we get some order in the chaos eventually. :wink:

Now you know what it’s like to work in middle management.

I use prioritise ranged and set chase distance to minimum (5m) and attack distance to maximum, then use either attack all enemies or guard area. I also place wooden boxes filled with a variety of arrows near archer placements so that I can do quick resupply and change arrow use during purges. This has been working for me.