The Wrong Kind of Message - Old Tarantia Quest - Can't Get It Again After Deleting?

I accepted the quest The Wrong Kind of Message from the NPC Novatus in Old Tarantia. In the quest you have to confront a Set priest about preaching his religion to citizens and try to convince him to stop. After completing the step where I had to have a debate with him, the quest updated to where Novatus had a turn in marker over his head. Instead of turning it in, I deleted the quest from the quest log, hoping to be able to redo it and choose a couple different dialogue options. However the log says it’s completed despite the fact the turn in marker had been on the guy? i’m confused what’s going on here. I don’t know if I got xp for it either. I have tried speaking to both NPCs and I’m unable to initiate the quest again.

If the quest log displays it completed, then its completed and you cannot get it again.

I am not sure, but I always thought it doesn’t matter how you debate the guy, he always gets triggered at me. Tried many different ways on different toons, and he always complains. not sure if class/race makes a difference.