Thrall AND Horse don't enter Palace of the Witch Queen

Game mode: Online official
Type of issue: Bug
Server type: PvE
Region: America

When I enter the Palace of the Witch Queen, my thrall doesn’t follow me into the dungeon. Also the horse doesn’t follow either. If I am on the horse when I enter the dungeon, the horse is there, however, when I move, most times, the horse immediately disappears. The thrall is no where to be found, and even commanding him to move to the spot in front of me doesn’t work. Thrall is still no where, to be seen.

Note, from the server list I provide above, I have tried this on two servers with the same result.

Since the thrall didn’t follow me into the dungeon, out of desperation, I tried doing the event myself with my gimpy all endurance build. I killed both statues by slowly wittling them down to nothing, but the Witch Queen spawned on top of me in the middle of the second statue. However, her pathing got her stuck against a wall and then I just beat her down, and she never attacked me, except the first time when she spawned right on top of me.

Something is seriously wrong with this dungeon.


Both thrall and horse were outside, still on follow when i left the dungeon. Never saw them once during the whole fight.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Put horse and thrall on follow,
  2. Enter the Palace of the Witch Queen.
  3. Horse and thrall do not follow

Hey @Lahaina

We’re aware of this issue. It’s been partially fixed in the current Testlive implementation of Update 2.2, but there are still a few related issues that remain unsolved. We’ll continue to iron them out.
Thanks for the feedback.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.