Thrall behaviour bugs

Game mode: [Online | Singleplayer]
Problem: [Bug | Performance]
Region: [EU]

As of late my thrall(s) have been rather insubordinate by refusing to do what they are meant to - which is fight.

They keep refusing to equip their weapon; or equipping it and then right away putting it back. Alongside this issue, is the fact that they seem to be constantly pathing to me as if they are in follow mode, which is not the case as they, like I said, are actually trying to initiate their attack and weapon mode but immediately revert to passive whilst also trying to “hug me” during an encounter.

Aside from just returning them to their cage and taking a different thrall out, I have found no way of stopping this stupid comedy act. That only lasts so long before this garbo happens again with the replacement. It isn’t a new issue for myself; but it wasn’t super common, and it managed to sort itself out after a short while; however, it’s been especially frequent these last two days and it is starting to really annoy me.

I have done Google searches, and it seems this has been an issue for some for quite some time; yet I can’t say I noticed it until I started playing online, and it started becoming more common once the “commands” and “rules of engagement” update. Is there going to be a conclusive killing of this annoying thrall rebellion at some point?

Other: It seems more common when I am bringing the horse out with us. Could it be… jealousy?

Steps on how to reproduce issue:

  1. Take a thrall for a spin.
  2. Eventually it will do this.
1 Like

Same happens to me very often. I manage sometime to reset their brain unequipping all armor and weapon and re-equip again.
Noticed also that equipping 2 weapons seems to fix it.
Waiting for funcom to intervene, I also have a video showing this if it can be useful for them.
I read in the forum that it can have some relationship with teleport using, but it’s not. Yesterday I walk all the road from my base to volcano, and the thrall stopped attacking almost immediately, at the volcano I tried equipping 2 weapons and I solved.

1 Like

Upon starting today, I went no more than 2 engagements (against low level trash no less) before the thrall completely broke and just sat there in attack stance when idle, and from then on just going from no weapon in hand to weapon out before reverting to no weapon over and over whilst constantly trying to “follow mode” me… with the usual “I’ll stare at the enemy and keep toggling weapons on/off” crap.

I’ve just tried this today, and it sadly did nothing to change this annoying behaviour.

Today I have tried a number of different variations to see if anything works. These include:

Filling their inventory with weapons filling it with items.

  • Changing the weapon to different types or the same type but a different version, or removing the weapon and giving it back.

  • Like you did, going a large distance on foot and the opposite, by going via teleport.

  • Going out with no horse and then with one.

  • Trying literally every combination of the “rules of engagement” settings.

And more - to no avail.

Please… I know the thralls are considered a little too good, but this nerf was not the answer (I know, I know, it’s a bug, I’m just being silly).

Funcom, what say you?

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.