Thrall gets Stuck, and stops following and answering any commands


Game mode: Online official
Type of issue: Bug
Server type: PvP
Region: [North America, East]

Twice now, I’ve seen a bug where your following Thrall gets stuck somewhere, and will no longer teleport, follow, or respond to any command… Back in the past you would walk far enough that he would just spawn behind you at one point… that doesn’t even happen, when this bug occurs… the thrall is stuck there until you either find him and manually move him… or log out and wait for him to return to previous guard position…

First was yesterday at the Black Galleon, on the ship itself, where there’s like inaccessible compartments just beneath the main level, my thrall fell half way in there, and wouldn’t move at all from that point on. Respond to command, nor would he follow/teleport behind me if I ran away really far…

Second was today, my thrall teleported under a draw bridge at one of my bases, got stuck there, and wouldn’t respond all the same as the above, until I manually moved him.

My thrall is configured in a follow me mode, attack all enemies, attack and chase distance set at 15m.

Thank you.


I have had this happen a few times as well.
When i was outside i was able to run very far and he ported to me. I think this is part of what leads to the confusion. We are used to the relatively small range that you need to be away from your follower before it ports. But that range has become a lot larger now. Check for instance behind you when you are on your horse from how far away you can see your follower come running towards you, it’s range is huge now!

And in that lies the problem, if you are in a dungeon or a smaller area like the black galleon or even something like new asagarth you cannot run far enough away for the follower to reset by porting to you.

1 Like

I had this issue last night when my thrall became stuck in a corner after I moved through a doorway (mind you he got stuck on the open side of the doorway which was a very wtf moment). He eventually joined me (unlike my horse before the hotfix) but after a good 5 mins of not having him with me.

1 Like

Me and my friend had a lot of this issue as well. The thralls are getting stuck inside stones and other barriers. I miss my always on the run thrall. :frowning: it don’t answers commands, don’t come, don’t move out of the stuck.

I’ve been having this issue all day. The thralls are broken now.
I’ve got the attack and follow limit set to 10 meters, and my thrall constantly gets stuck and/or stops aggro and gets brutalized in the process. I lost my first thrall in a long time today. PLEASE FIX THIS FUNCOM. It was better before. Roll it back till you can get it right please.


Can confirm, this has happened a lot to me. Thrall gets stuck in a random ■■■ spot, sometimes i can get far enough away and tell the thrall to move and it works. Last few times took me 15-20 mins for him to get unstuck.

1 Like

Roll it back till you can get it right, please. (2) I was really enjoin’ the game! :frowning:

1 Like

I have experienced similar issues.

On one occasion the thrall killed a frost giant and appeared to be stuck in the carcass, nothing worked until I got rid of the carcass and even then, took me a while to get him to move. I honestly cannot remember what finally allowed the thrall to move as I was doing everything from kicking it to issuing move commands to running out of rendering distance.

Second time was when a thrall was fighting near a foundation and on a knock-back, got too close to the foundation? Graphics did not show him ‘in’ the foundation, just close to it and he was stuck for 5+ minutes. Again, was doing everything to try and get him unstuck but cannot tell you what actually worked after these 5+minutes as it was during a raid and active pvp battle with a lot of players.

Thralls are also showing up at odd places on server disconnects. It used to be that the thrall would scout near where the disconnect happened but as of recent, I find them everywhere- maproom taken prior to disconnect, last guard position prior to disconnect, prior obelisk taken and once in a while- actually near disconnect location.

1 Like

Hey! I’ve found out that thralls DO teleport to you, or at least that was my case, but the distance you need to cover is huge now, easily 3-4 times the old one. Also, it doesn’t even need to stuck in strange places. If you jump off a sufficiently high ledge (or climb up one), chances are your thrall won’t follow now.

Ride a horse and thrall will be reset to you!

Please, roll back it till you get the needed fixes! :frowning:

1 Like

I had this issue yesterday in a dungeon. I couldn’t get my thrall to move before he was stuck. I finally tried skinning the wite corpse at his feet and doing that freed him. This update is killing me.

Have you used the move command? The only time I have an issue with thralls not moving when giving this command is when they get ‘stuck’, usually when fighting something.

Yeah, and same result. If they’re too far away, they don’t seem to obey any command until you’re far away enough for them to finally teleport to you.

Hey @blazarius

Welcome to our community and thanks for the feedback.
We’ve relayed it to our team so they can look into it.


I have to double check this… but might have found a mini work around…

1st get ur thrall stuck… not too hard these days…

2nd move away see he dont teleport…

3rd while being away… give him a move command… close to where u are…

4th move away from him a bit more… and then he spawns(teleports)

I will be testing this more 2nite… Will come back with feedbacks

so short answer… no… its not a perfect work around… it worked a few times, but then some Stone rocks blocked my Zerker in volcano… and nothing to be done, until i mined the stones,

This has been my method till the system gets adjusted works about 90% of the time. Sometimes I might have to repeat it twice. When it doesn’t work I have just had to move a lot farther till the thrall would tp back to me then it would work again. I can see how in tight quarters this method can be a bit much which is why atm I am just sticking to the outdoor camps till we get a fix.

This does not work for your horse since it is not a “regular” follower that you can give commands.

Me a pasado alguna vez