Thralls are not attacking enemy


#1

Game mode: Online
Problem: Bug
Region: UK, PVP High populated private server


We prepared Archer thralls, equipped them with bow and arrow. Placed them on foundation.
Once enemy arrived and attacked, they were not doing anything. Some of them just bugged in running animation. They were wearing flawless heavy khitan armor and sandstorm mask. Bow, dagger in inventory and one poison arrow on the bow (we tried also more arrows, but it didn’t changed anything)


Steps on how to reproduce issue:

  1. Equip archer thrall
  2. Place him on foundation
  3. Get attacked

#2

So apparently this is because the PvP building damage was off for the time period. Thralls counts as a buildings at this time. Weird, but not a bug then.


#3

Everyone on my server has this issue PVE-conflict server 1942, if its building damage times that it only works then that makes sense because there are no building damage times for pve-conflict. This is what happens, they all just form a moshpit around the enemy, I was lucky earlier and one out of all those thralls actually started attacking the king elk, but i tried again with a wolf and nothing, they just stand around. Since i’m offline the majority of purge hours this is really concerning, I have no defenses.


#4

It’s not just owned thralls that are doing this, at least, not on the server I’m playing on now (1502). All NPCs, human or other, go through long periods where their aggro radius drops to about 10’, and sometimes they don’t aggro at all until they’ve been hit themselves.

Then it’ll randomly fix itself for a few minutes or an hour, and they’ll go back to aggroing normally, and then bug again. This made it impossible for me to kill the Abyssal Remnant (couldn’t get it to attack me at all, let alone flop out of the pool) but it sure has made raiding the Black Galleon a lot safer!

On the other hand, half the thralls I want are under tents, and therefore immune to being attacked. So there’s that frustration. It’s how many days until the devs start working on the next patch?


#5

For the thralls under tents that you can not hit …try this:
Melee hit one part of the tent they are under … I usually aim for any wooden pole… then attack the n p c …without fail since the big 500+ patch on PC which messed up NPC aggression… THIS has allowed me to damage an “under a tent undamagable humanoid NPC”. It only takes one strike on the wooden structure to permit me to then damage the NPC…and them to fight me back after I have initiated the attack. I do not need to destroy the tent.
I have not tried shooting the tent to see if I can then damage the NPC. I have not tried hitting only the fabric or rope on a tent.
Qualifier: I have only tried this with one particular one-handed sword, so can not confirm it occurs with all melee weapon types. If you are thrall hunting, then I can confirm that after i have done this so they can be damaged by me I can swop to an iron truncheon and knock them out.


#6

Can confirm it from my server pvp official 1398, all npc be it thrall or not they just do not aggro unless they get hit themselves kinda ruins it when im out adventuring. It was even on pvp raid times and not… Just so happened i got raided last night and my archer thralls just stood idle while im getting pawned, some fighters went to the enemies but didnt see them attacking not sure if they did their job properly… but the archers :cry: ive seen one of em shoot then stopped after 2-3 shots…


#7

For me, when i kite an enemy to my thralls, even if the enemy hits them point blank they usually just take out their weapons for like half a second and then put them away and stand there. They wont even attack if they get hit is what i’m saying, I’ve tried at every part of the day (non-pvp hours, pvp hours, purge hours), the best I’ve had happen was one tier 2 fighter thrall somehow by magic got aggroed to the king elk. We need a hotfix for this.


#8