Thralls in Isle of Siptah become invisible permanently = Isle of Siptah unplayable


Game mode: Single-player
Type of issue: Bug
Server type: PvE
Region: my pc

In Isle of Siptah thrall becomes invisible.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. recruit thrall
  2. place thrall
  3. thrall goes invisible without rhyme or reason and stays that way even after reboot
  4. only deleting the savegames from the time the thrall became invisible restores it, but it happens again anyway

I’m not the only person suffering this issue. A game about capturing thralls. Thralls go invisible in game. = Not good Funcom. Game unplayable.

Note that never has a thrall or pet gone invisible prior to Isle of Siptah.


Are you running mods? Have you tried verifying the integrity of your game files (after removing mods). It doesn’t happen for me neither in my single player games nor on my servers.

Followed your steps and I have no issues. My thrall is visible.
Are you using mods?
Are you playing on a private server or official server?
What thrall are you placing? Does this happen with different thralls?
Can you pin point the location on the map where you’re placing the thralls?
Are you playing single player or co-op?
Can you provide some screenshots or a video as proof? My thralls turn into unicorns at night, but noone believes me because I have no proof of it.
Are you experiencing glitches or artifacts on your screen while playing other games? This might be related to a faulty video card.

1 Like

Zero mods. I recruited a single Lemurian Dancer II from one of the summoning portal thingies in the sky. I place the thrall. It was visible for a while. At some point the thrall became invisible after I placed them to guard my wheel of pain. I came back to see it gone. I inspected closer and when you approach you can get the thrall’s name bar, even open their inventory and transfer items and see the preview of them, and, interestingly if you equip a weapon in their hand it will show, even if they are dancing (and the weapon stays relative to the hand throughout the dance, which is badly amusing).

Upon first occurence and finding no way to fix it in-game, I deleted my save game and went back to the one where the thrall was on the wheel. I did this a couple of times. I placed the thrall, it was fine for a bit, then at some point it disappeared. Once it disappeared while following me in my base.

Um, sure, I can definitely provide screenshots. I can put a screenshot in here? Let me try, I will learn how and reply with a screenshot then.

OK I have no idea how to put a screenshot in the thread. I don’t see a button for it. How can I do this please?

Oh, will this work for you for the screenshots? The link to my screenshots in Steam?

Hope these links work, please let me know if they’re broken. I would REALLY like to be able to play Isle of Siptah single player. As per the previous “horse not tilting properly with terrain” bug only encountered supposedly in single player, I hope this isn’t another one of those graphics glitches, because it took them until Isle of Siptah to fix that, and now in Isle of Siptah itself there is this new unplayable bug…

Oh and sorry, to specify more clearly, this is entirely “single player”, in “decadent” difficulty setting, graphics maxxed. Running a pretty serious rig I rarely have any issues with with hundreds of games: i9 9900k with a RTX 2080, 32GB ram, installed on an SSD, Windows 10 Pro, no tweaks or mods whatsoever to Conan Exiles.

1 Like

For further information, I would like to mention also that it does not appear even going back to any save game when the thrall was visible fixes it. Only going back to the save game before you placed the thrall will allow you to take it off the wheel again and place and see it. Then it disappears at some point, or after the next time you boot the game, never to reappear again, except, as I mentioned, to go all the way back to before the thrall becomes your follower. Hope this helps. Hope someone can fix this, I’d like to explore Siptah.

Here is another thread apparently about the same exact bug as far as I can tell:


1 Like

Try to verify the integrity of your game files for Conan Exiles.
Right click on your game in steam browser-options-local files-verify integrity of game files… .
From the looks of it, the game can’t find the mesh for your thrall. Could be a broken refference in your game.
If verifying files doesn’t work, try to reinstall the game.

OK I’ll try verifcation of file integrity through steam first and let you know.

OK, verification of files had no effect. I’ll have to reinstall later and let you know if it works.

Reinstalled the game. Still no effect. Problem persists.

It’s unfortunate that Funcom continues to release content that appears not to have undergone very thorough testing beforehand. This is a pretty fundamental mechanic of the game: capture a thrall, tame it, then place it and use it. There isn’t much of a game here without all that, aside from the building. How does this not get tested?

I can verify that I have the same issue in single player with invisible fighter thralls. Their name is still there floating. I can pick them up and move them, and they’ll reappear while moving until placed.

Not really a solution, but Exit to Main Menu not completely shutdown. Then, load the map again and they reappear as normal.

1 Like

Ohhhh? I’ll try that! Thanks for the tip! Would be nice to play Siptah again!

Funcom, please read this thread and address this issue!

Edit: Going out to main menu and restarting the game from there makes the thrall reappear. Thanks for the tip! Can play now at least! W00t!

If I put the thrall on guard and walk away out of render distance, it also reappears.

I have this problem when starting the game in my base. Only the thralls on the stations appear. All other thralls are invisible like in your screenshots. So I walk away until my base disappears and when I return the thralls are visible.

Sweet, another nice tip.

Thanks to all you guys I can now play it again at least with the work-arounds!

Hey there,

Please be aware that we’re not at the office during weekends and therefore can’t check the forums during that period of time.
Thanks for the feedback, it’s been relayed to our team so they can look into it.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.