Thralls not following properly on Single Player

Game mode: [Singleplayer]
Problem: [Bug | Misc]
Region: [US]

Was hoping this was fixed with the new Thrall update, but sadly not. On single player on the Xbox (regular Xbox with game installed on external drive) Thralls don’t follow properly. They won’t teleport through the map room with you and even in admin mode they refuse to teleport across the map.
The Thralls will not follow you across any water hazards, they stand on the opposite bank and won’t teleport across to you.
They also will not follow up or going down while climbing any structure.
They also will not teleport into any of the Dungeons when your characters enters them.
They also seem to just get stuck and not follow on normal terrain causing me to backtrack to get them to start following again.
The only way I can teleport with a thrall is to pick them up and teleport to the desired location then place them and set them back to follow which also works in the map room. I can do the same with the Thralls to get in a dungeon but can’t place them.
And I have waited at times up to 20 minutes to see if the will teleport to you but they never do.

Steps on how to reproduce issue:
1.start single player offline game
2.set Thralls to follow
3.try moving and teleporting with Thralls
4.thrall refuses to follow

Hello @wowhunter1967, thank you for reaching out!

Does it also occur in online play?
Which specific thralls did you use?
Were they placed after or before the update?

We’ll register the issue for the developers to look into, we would really appreciate it if you could share a video of the issue in effect.

Thanks for replying. This only happens in single player for me, online works fine. This bug was there before the update and it still happens after the update. It also happens with any thrall, newly placed or ones that were placed before the update.

1 Like

Thank you for clarifying, we’ll send note to the team with the additional details.

I also have this thrall following problem on my main single player game. I have an original Xbox One and this game save has a large number of buildings scattered around the map. Currently, this particular single player game file crashes when opening up the inventory menu, so I haven’t been able to see if I still have this problem. This game save has been around since the game was released on early access on the Xbox One.

I do have a newer single player save on an different Microsoft user account that is fine and the followers work as intended (they don’t swim though) in dungeons. The only difference is I have much fewer thralls and very few bases on this game file.

I started a new single player and it still happens. I will try on another user account and see if that matters. It’s just weird that it’s fine online and not offline single player

Well I took your advice and tried my other Xbox account and the Thralls are working as intended. I never thought to try it thanks. It’s just hard to believe that a different user account would make a difference

Glad I could be of help. Do you mind if I ask you a few questions about your game save? Maybe it can help the devs zero in on the problem.

  1. Do you have a really large base or a number of bases on the map? Are there many placable thralls at those bases? Maybe going over a certain large number of thralls causes this bug on Xbox.

  2. Have you ever had a thrall that was following you suddenly die or disappear? Have you received a notification like “[type of thrall] that was following you has died”? I have a theory that the thrall gets stuck and when you go out of render distance, the thrall falls through the despawned ground to its doom under the mesh.

  3. How long have you been playing the game? Were you a part of early access? The game has changed a lot since its release and it is possible one of the prior updates affected the game save in some way or something.

  4. What version of Xbox are you playing on?

For me, I have over 20 structures in the game (not all bases; some are fancy map rooms near obelisks). I probably have 80-110 placable thralls total across the map. I also have lost a number of followers, especially in Seppemaru. If I go thrall hunting (for Zoara of the Marshes) I usually take a low level Seppamaru dancer with me as they can knockout other thralls pretty quick and are very easy to replace. I also have been playing the game since early access so it is an older save file and with no real way to delete older save files (your structures still remain if you recreate a new character) it makes me wonder if this is why your new game save still has the same problem. I play on an older Xbox One.

Hope this helps and @Hugo please spread this info to the dev team. It would be greatly appreciated and hopefully shed light on this issue.

I’ve never really had a big base or a lot of Thralls on my single player with a lot of placeables . Mostly test things out like build designs, new items and dungeons. I have restarted the single player numerous times but never had any thing carry over from save to save before. I’ve been playing since it was available for the Xbox and before that I played on my laptop through early access. I haven’t tried to delete my saves on the Xbox but I thought a clean install would fix it. Well of to the drawing board again.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.