Two beds but only one in house

Game mode: Online private
Type of issue: Bug
Server type: PvE
Region: America


I die when I login to the game. Almost every time. This time when I died I, for some reason went to view the map. I noticed, on the map I have two beds. There is only one in my house and the other does not seem to be anywhere in or around my house.


Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Login to private server
    2.build house
    3.Place bed
    4.check your map

Your bedroll has the same indicator on the map as a bed. could that be it?

1 Like

Is the mark on the map that is not your bed, by any chance a bedroll?

I took my bed roll up when I placed the real bed. I have searched my house and outside. I will login right now and see what happens, but I predict another death coming.

1 Like

Ok, I did not die this time but I had my armour off so that is probably why no death. I now know that the map shows the second bed outside of the walls of my house. Where I have never even camped before. I took up the bed I placed in my bedroom and it still showed a mark on the map for that bed as well. I looked up in the sky thinking it could be floating around up there for god only knows whatever reason, lol. It was not up there. I have no idea what is going on.

See this is private…are you running any mods?

Nope, completely vanilla.

Hi @bigguy80, was the bedroll you picked up placed in the location of the marker that has persisted?

Could you also state what messages you get on the Event Log when this happens?

1 Like

No I don’t think so. Hard to remember now. It was when I was building my house and I only had 4 foundations down. I placed it on them. After I finished the upstairs I moved the bedroll to the bedroom. Aah yes. Now I remember, When I put the stage floor down on the regular floor I had to pull up the bedroll. After the stage floor went down I made a regular bed and placed it just over from where the bedroll was, so you are right in what you say.

For your second question I would have to login to our private server to see if there is one. It started awhile ago. I used to go to bed with armour on and thought that was what was killing me. Then it started with no clothes on. We turned on don’t lose anything on death so I still have all my stuff and my clothes are in the cupboard. It is real annoying though. Let me login and see if I can see the logs. I’ll be right back.

EDIT: The bedroll on the left in the screenshot was the first bedroll I put down. I pulled it up and put down a bed beside were it was, which is the bedroll on the right.

The error message in the log says this:

bigguy80 (Brothers Grimm) was killed.

That’s not very helpful but that is all. I also noticed in the logs, that we have our server set in G-portal to restart every morning at 5 am. But it does this 3 times in a row for some reason. Not sure why that is but we will talk to G-portal about that.

Well…we can mark this solved now. I figured it out. And, I feel reaaally stupid. When I found this place on the map to build a new house I had to go back to my first house and get some stuff so I put a map marker down…guess what it looked like…yeah, a bed roll. I forgot I had marked it on the map. Sorry all for the trouble this caused if any.

I still have a problem with dying on login though.

2 Likes

As for dieing when I login. This first screenshot is not how the game is supposed to load:

When I do get into the game it looks like this:

Already dead. Something took my arms off:

Screenshot of eventlog:

1 Like

I usually set temporary map markers by parking a thrall there and turning on their map icon, but I’m glad you got that issue figured out.

2 Likes

I gotta a bit of a bad memory at times but yeah, I’m glad that is solved. Now just have to figure why I die on login.

Try not logging off on the bed but elsewhere.

1 Like

The problem is it does not happen all the time…I will try that though, thank you.

I don’t remember which ones, but I remember not long ago reading threads saying that certain beds had clipping/loading issues where you would die upon login. Maybe it’s one of those beds?