[UI/Item] Anniversary Sub bonus armour not showing up in Claims page

I’ve purchased one of the Anniversary Sub offers that includes the Armour bonus. Payment has processed, it even says “with bonus” on it in the payment info. The FC points show up but the armour itself (and the nanocans) are nowhere to be found. They do not show up on the Claim Items page of the Item Store, where previous years’ sub bonuses show up. They do not appear in the Mail system. They are not in any of my chars’ inventories. They are also not available to my RK2019 characters on the account. I’ve tested this with a fresh AO client install that has default UI settings, so it’s not due to a UI addon hiding it.

Steps to replicate:

  1. Purchase Anniversary sub with bonus
  2. Look in Claim Items page - Preserved Colonist set is not there

Other information:
The account in question is the one with the character Ophiuchus, however this appears to have happened to some other peoples’ accounts as well.

sorry to hear that =( have u tried to send ingame ticket? i just wanted to buy 12xmonth sub for 2-3 accounts but holding now…

You have to manually click the “Pending Rewards” button at the bottom right corner where the shop/daily rewards are per character.

They are not in “Claim Items” in the itemstore nor do they “claim” by default off pending rewards by the “Daily Rewards” claiming.
Pending rewards

Aha, that worked for me! I’ll pass it on to the others.

Weird that it’s done differently to e.g. Dustbrigade Technician set from a couple of years back…

They started doing that since RK2019 with the frontline surveryor armor set unfortunately.

However it does allow you to claim on new characters in Arete! Since it doesn’t need the mail system to claim.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.