Unable to attach sloped roof piece

Game mode: Online Private Server
Type of issue: bug
Server type: PVE

While putting a roof on a couple of my buildings the silhouette for placing a sloped roof pieces does not show up, it always happens when I’m trying to add the last sloped roof piece in the middle of the roof, all other pieces on the 3 other sides went in fine, or the one on the opposing side won’t go in either. I’ve been playing this game a while and I know how to put a roof on a building, it seems to happen most frequently when I’m using the Frontier style building pieces. have no problem placing corners or roof caps. When this happens placing a foundation piece I just go do something else and come back and am able to place the piece, but for 2 days I’ve tried to add the last sloped roof piece to my vault building, and now I built another building and I can’t add the last 2 sloped roof pieces in the center of the roof.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:
1.start putting a roof on a building
2.get almost done and no silhouette shows up to place the middle sloped roof piece
3.log out and refresh server, still not able to place that last 1 or 2 pieces of sloped roof

I’ve had this happen on PS4 as well, and it’s a very annoying bug, one that shouldn’t really be happening. Then there’s the variation of it, where you’re ready to place the last sloped roof piece you need to finish it, and the silhouette only appears for the angles you don’t need, upon trying to rotate it to get the angle you need, the silhouette vanishes. I find it happens with every building set though, and it’s only ever the sloped roof piece, as you stated.

1 Like

Thank you for letting me know that this isn’t another bug that seems to only effect me. I agree it seems to only effect the sloped roof piece, I only use 2 styles so I haven’t noticed it with any other. I also see “failed to place building piece” a lot as well.

1 Like

Hey @BigSarg

Apologies for the frustration. We’ve relayed this information to our team.
Thanks for your feedback.

Thank you Ignasis !!

1 Like

One thing that’s always worth checking is building stability. I know you said you know how to build roofs, but sometimes it’s easy to miss the obvious. I know I sometimes fail at counting the number of foundations correctly before placing roofs and end up encountering the exact problem you describe, ie. the last two roof pieces won’t snap.

That said, the roof piece placement does have the occasional bug that prevents placing a roof piece even when the stability is confirmed to be good. Still worth double-checking the stability because sometimes the bug is in my head.


the roof pieces are in the middle of the roof, not the end, so if I can place a sloped roof piece to the left and right wouldn’t that mean that the building stability is good? How do I know if the building stability is not good? Do I need to tear it down and start over? I figure if everything else went up fine (foundations, walls, doorframes, roof corners, ceiling tiles, other sloped roof pieces) the middle sloped roof pieces should go in, I can even put a roof cap on.

Get a Repair hammer, wield it and point your character at the roof pieces around the hole you’re trying to plug. (I think holding the Tab key also works if you don’t have a repair hammer.) If the Stability of the pieces just below the hole in your roof is 20 or lower, you can’t build sideways from there. If that’s the case, you need to build additional support under some roof pieces.

Good info, thank-you, even if it doesn’t work on this particular issue its still really useful information! I will try it the next time I log in.

So I tried this, it did help to a point, now the silhouette shows up but I can’t turn it in the direction I need it to be.

This is what it’s doing now.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.