Unable to craft Twitch drop items (items not found)

Yes but it wouldn’t let me reconnect
Ps4 last gen
And still got nothing

  1. Have you tried disconnecting and reconnecting your Twitch account? Yes get error saying account already connect
  2. What’s the exact model of PlayStation you have? PS5
  3. Have you learned Furniture Making and Exile Epics? Furniture making yes exile epics no level 52
  4. In single player, can you see or spawn them with the Admin Panel? Can see them in admin panel single player can’t spawn them
  1. Have you tried disconnecting and reconnecting your Twitch account?

Yes, I disconnected via the twitch app on my phone and after trying to reconnect I received an error message: 1012, but even with the error, the reconnection worked.

  1. What is the exact PlayStation model you have?

I have the Playstation 4 fat model, with the latest software version.

  1. Did you learn Furniture Making and Exile Epics?

Yes, I learned both talents, on an official LATAM server.

  1. In single player mode, can you view or generate them with the admin panel?

I can see the items in the menu, but I can’t create them.

Have you guys been able to get it happening internally on PlayStation @AndyB?

  1. Yes. Got the typical existing connection error, but it did eventually reconnect.
  2. PS4 Pro
  3. Yes, got them both
  4. I can view them in the admin panel but cannot spawn them, with a similar error message to attempting to spawn Conan’s Royal Armour, and what I imagine is the error message for attempting to spawn DLC pieces one has not purchased

Thank you for working on this.

Hey all,

Quick update just to confirm: We’re aware of this issue affecting the PS4 platform and we’re looking into a fix either from our backend, or coming in a future client patch.
For now, if you have claimed these drops on your Twitch profile, they are safe and will be visible and craftable once this issue is solved.


My guess it’s a Sony communication error with twitch drops.

1 Like

Even though you only addressed PS4, I’m assuming you mean PlayStation in general because PS5’s are affected by this too, not just PS4. I’ve claimed all my loot and haven’t been able to spawn any of them in my private server since day one.

Thanks to the team for working on this!

1 Like

I’m pretty sure it’s not Sony. Funcom didn’t test their link system with Twitch.

1 Like

Thx for the info.

“Future patch”, hopefully we’re not waiting another year like version 2.3: :crazy_face:


I wish I even got the opportunity to claim the rewards. Linked my twitch as was instructed, watched the streams every day for at least 2+ hours, and never even got the prompt to claim anything.

Thanks for the update.

Any chance of foot gear being added to the watcher set in the meantime?

I figured it’s a more reasonable ask than a watcher’s hottub furniture item or spider silk hammock style bed.


Hello @WalkedPaladin1

If there was no claim notification, then I believe those streams didn’t actually have “drops enabled”.

I explained on a different post that Twitch sends out three notifications.

Dear Ignasis, as always, you’re always giving us a light, at the end of the tunnel, I understand that mistakes can happen, as the technology is more advanced, it will always be error-prone, but by God why only on PS4. this is wrath of the gods of the exiles,???


But they all had drops enabled in the title, and I watched different ones each day.

1 Like

Sorry, the title doesn’t count. Those streamers didn’t link their account properly, I found many with “Drops Enabled” on the title and sadly my progress bar didn’t move and the notification was never sent for those specific streamers.

The proper way to check if they are setup properly is on my previous post:


They did have the tag. I’m also talking like hours of time where I’d turn on a stream and let it run. Then switch to a new one if that ended. Till I went to sleep of course.

Where did you watch twitch?
Twitch app on phone?
Twitch app on PS4/PS5?

Some of the ways you can watch twitch don’t support drops. So even if the stream had drops enabled, if you were using a twitch client that didn’t support drops then it wouldn’t count

The PS5 twitch app for instance doesn’t support drops. I don’t know why Twitch doesn’t support drops in all clients but they don’t.

I first started in PS5 twitch app and then when that didn’t work I did some looking and I found twitch documentation about which clients support drops. So I switch to the twitch app on my phone and that worked.


Laptop chrome browser.

Well, looks like a second chance might be available for those who missed the claim, or had issues watching streams with the drops.