Unable to Get the Cat God mission

Hi

My friend and I completed the Meowling, and we received the quest completion message/rewards. However, when we interacted with the stone to try to get the follow-on Cat God mission, we got a progress bar and then nothing. We tried this repeatedly, tried logging out and back in, exiting and restarting the game, but nothing worked.

On one occasion, a long time after we last clicked on the stone, a portal suddenly appeared, but we were unable to interact with it in any way.

We both submitted petitions, but as with every other petition I’ve submitted in the last year, there was no response.

Two things:

  1. On completion of The Meowling, you may get the Cat God mission automatically if you don’t currently have a different action/sabotage mission. Have you checked it is in your missions list?

  2. If you don’t actually have the mission, that mission pick-up is completely borked in that you have to stand at an absurd angle to the stone to actually pick up the mission. Basically, if you feel stupid for even trying, you might be in the right spot and looking in the right direction. And after picking up the mission, you have to click on the stone itself to get the portal.

You could try shouting out in chat whether anyone is willing to group up and share the mission.

As for petitions:

  1. Have you made sure your petitions were actually submitted? People often overlook the final confirmation step on that.
  2. For this issue, a GM would probably have to catch you online; it’s unlikely to be an easy offline fix like certain inventory-related stuff.

Hi

Thanks for the reply.

I checked, and I don’t have the Cat God in my mission list.

I tried different angles relative to the stone, but no luck. I’m not sure that I really understand what you mean, though. Do you mean the direction I’m facing?

The other problem is that the stone no longer shows a mission icon, so things just seem to be getting worse.

Regarding the petitions, in every case I subsequently went back to the Petition screen and saw that my petitions were in the list. All 4 of them were completely ignored, and have still never received any response, even after months have passed. I also opened an case on the website, but the last 2 times I tried that it took 2 weeks to get a response, by which time it will be too late.

I’m upset that it looks like I’m going to have to miss this for the 2nd year in a row, and I’m hugely frustrated with Funcom for messing up this mission, and for their unwillingness, for over a year, to answer a single one of my petitions.

Hey there, Skyh. Sorry to hear of the trouble. I’ll be DM’ing you for more details about this issue.

I logged on for a 3rd time, because I was going to see if I could pick up The Cat God from Madame Roget. Since I was already at the stone, I decided to give it one more try, and this time it worked. The portal appeared, and the mission icon reappeared as well.

So at this point, I’m more concerned about the problem I’ve had with no response to petitions.

Update: apparently the problem hadn’t fixed itself - Funcom customer service manually added the mission to my character. Thanks for that!

And hopefully this forum will serve as a workaround to problems with in-game petitions, as it did today.

Possible workaround in future: a couple of days after completing the Cat God, I picked it up again from Madame Roget, and after that the portal did appear when I clicked on the ritual stone.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.