Unable to place shrine/temple

**Game mode: Online official
**Type of issue: Cannot build mitra shrine in the exact same spot I had it built earlier.
Server type: PVP
Region: North America


I am building a multi-level base. I built a shrine in the middle as I was building upwards. During building, I was having issues with the ceilings “building” in certain places. I am aware a work around for that is to destroy surrounding attached pieces until it allows it to place.

During this time, I dismantled the shrine. A few minutes later, I tried to place another shrine in the exact same place. Could not build. I tried manipulating height and depth, nothing helped. I simply could not build this shrine in this room. I tried building the shrine in a larger room below and still, couldnt build. I was getting the error that something was obstructing the placement, but nothing was there.

I figured maybe i needed to wait for server reset to let everything “bake” into place, and I’d try it again. This time, I tried to place the shrine and it said “this will block your spawn point”. I thought to myself, well thats interesting, my bed is a couple of levels directly above this spot. So I picked up my bed, and went back down to place the shrine, and I’m right back with the red text telling me something is obstruction placement.

I’m wondering if the spawn points saved interfere with building later (until a server restart). I’m following the logic. I’ve built my bed elsewhere. Now I must wait for another server restart.

As for now the problem remains…

2 Likes

Hey @A_Nightfury

This looks like a pretty weird issue. We’ll send it to QA and see what’s going on with that.
Thanks for letting us know :slight_smile:

1 Like

It’s looks pretty weird yes, but that’s how vanilla is often working unfortunately now.

The spawnspoint point thingy is coming back often. Also often we get message that it’s not allowed here or obstructed.
But i guess, that the price we have now to pay for all “anti-cheats” and “anti-griefs”, “meshi-mesh” probs and more, people are asking so heavingly for all the time. Or at least some do.
Yes, when it comes to the building system, i’m becoming a bit salty, i’m sorry.

But i knowed this game in EA, and the buidling system was one of the best, smothest and funiest i ever know in a game. But then started the unending game of cat and mouse, and the griefing-war and all these bad things.
Now, for me building without a mod allowing smoother and friendlier building, isn’t simply no more possible. Thanks to Multigun, and many other mods, the game is still fun and enjoyable for me even after thousans hours. But still, yes, i have some regrets and nostalgy for the old, smooth building-system. :wink:

Thanks to you for your still helpfull hand, Ignasis, have a great day !

1 Like

For what it is worth A_Nightfury, after the second last FC patch my base, which is near Mek-kamoses Spine, I started seeing my character ‘floating’ over one or two foundations. Then the last patch came out and my base ‘split’ around that ‘float’ area.

Basically, I think that if you build too close to in-game spawn points then there will be issues. I understand that this is because FunCom are sorting out more of the issues that allow the Griefers and Exploiters to build below the ground, etc. I went over those three foundations with a repair hammer and there were no values listed - as if the foundations did not exist. I removed that bit of my base and had no issue after that.

I am guessing that this could be affecting your temple placement? You did not say where it was?

If you are near a spawn point or a main storyline place or town or city, that could be your issue? @Ignasis

I have this with a maproom, I can place a map on a flat surface made up of foundations and then pull up walls around it, with enough space between map and walls, but when I take up the map and want to place it again in the same space, I am not allowed to do so.

Yes, sure, this may also happen with shrines, and fountains, the mitra ones especially.

They have a big radius, as long you build around them, all is fine, but if you remove and want replace them, mission nearly impossible. That’s why i let still lot place around them, if possible. But had also to learn it the hard way.

If there’s any sort of restriction because of in-game content, he shouldn’t have been able to build in the first place on that spot. This report tho seems to imply there’s some sort of “ghost” mesh of some sort after placing an item, or some sort of interference with spawn points built on different levels.:confused:
Anyways, if there are any locations modified after a patch, a building would be most likely destroyed or blocked by the new restrictions.
We’ve sent it to QA and see if they can figure out what could be the problem here.

1 Like

Sorry about your issue, @A_Nightfury. I can’t add to the correction, but can offer this.

I often get a ‘too close to your spawn point message’ when attaching a piece to something with 20 stability and no other supporting members. The simple example is a set of stairs. When I get too high without another support that message pops up trying to place another object atop. This is nowhere near my spawnpoint.

I pondered this for a bit and finally thought the game was using that phrase to tell me ‘placing this object would result in zero stability’. So, I destroyed the last staircase, found a way to increase the stability, like a ceiling tile with a supporting pillar. Message gone, staircase continues a couple of levels.

I think in some cases the message is applied incorrectly, so take that with a grain of salt :slight_smile:

Regards

jim

Edit PS: Good report, well written. The only thing I would add is the specific location of the building. I do not remember the command, but @Vattende could give you that?

1 Like

I have seen on Live that any foundations that are shifted slightly below the surface of the ground using SHIFT auto-explode now. This is definitely new, and very positive re mainstream servers as it completely messes with the griefers/exploiters :ok_hand:
For me, I quite liked it as an Admin because it allowed me to make sure certain players do not mess about with spawn points. Now it just means I need to be more alerrt so not issue :slight_smile:

1 Like

ToggleDebugHud :wink:

1 Like

While spawnpoints and maintain them is important, i can also understand some frustrated players, often newer ones. That’s why i try to tell them to walk a torch or foundation around before they start to build.
This avoid often the nasty last foundation or wall you can’t place cause to near to a camp or such.

And yes, it’s important that exploiting the system is avoided, but it’s also important that the buidling remain fun and without unnecessary hassle. Not still an easy to go the middle way, that’s sure.

2 Likes

good points, @Vattende, I tend to use a pet for the same purpose since when in a new place it’s always at hand. The same applies (thralls too BTW), you can’t set a critter to defend a place that is restricted from building.

And my middle ground is usually a hole I can fall in :wink: Can’t even imagine how difficult that is in development.

Regards

jim

2 Likes

Just as a follow up, I waited until after server restart, alas I still cannot build the shrine. If someone wants to take a closer look at my problem, i’m on official server 1536, and i’ve built inside of the Watcher of the Passage (in the jungle). I did notice there was something wonky going on with the “head” of the building that jets out over the cliff. When i put an elevator on its nose, it gained all of the decay timers from the rest of my base, built up above inside the building only. Very interesting, because I could put a block on the ground in between those two points, and it would not absorb the decay timer. It seems to me like the dimensions of this structure have not been defined properly.

It seems a bit more complicated to me. Take an Animal Pen for example. I can put it on foundations. It will “sink” in them a bit, and everything will be OK. But if I’ll destroy one foundation piece near the Pen I can’t just put another one in it’s place because “sunken” stairs of the Pen don’t let me put anything here because of their collision box. It could be such thing: he put Shrine then built something more. Moreover, it seems to me that the game now tells about “blocking spawn point” by default when it can’t determine some error: I’ve got such messages when building in the open very far from any bed or bedroll (in SP). I had to put building piece back into inventory and then to place it again - and after that it snatched into the same place OK.

1 Like

The blocking spawnpoint issue is a very old bug from the past. Still jumping in from time to time after patches. Happens ever with no bed/bedroll around.
But may often be triggered nearby npc’s camps, ever if building is just allowed there.

And yes, same experience made, some structures like shrines, wells and other biggies, they do well if you build them first, then build around them. But if you remove them for any reason, often they can’t be replaced at the same spot. The other elements around will block mostly, and must be destroyed before replacement.

1 Like

Yep. This. Except in my case the shrine would not build in the same place it was before.

I’ve tried destroying everything around it in this case, but I think it my be bad coding with regards to something built above or below it. I have tried everything short of demolishing the entire base and starting over. I’d rather not do that, but I might…

1 Like

Did you try demolish just the problematic parts, then go out of render-distance. Or at worst, waite a server restart to see. Once demolished it’s demolished, that the final solution i mean.

Give it a chance more ! :wink:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.