Unable to Purchase Aurum


When I click on the Aurum Purchase icon on the top bar, or the button in the Exchange, nothing happens.

I tried restarting the game, but that had no effect. I rebooted my computer and restarted SWL, but that did no good.

I finally tried running SWL on a different computer, and got the same problem.

((I’m feeling anxious after seeing all the posts about non-existent customer support. I hope that situation has improved.
I also opened a petition, but I have very little hope as in the 2 years I’ve been playing SWL, I have never once received a response to a petition.))

Thanks …

Hi Skyh, thanks for the report.

We’ve confirmed there’s an issue with some web services at the moment, including the Aurum interface. The appropriate teams have been alerted to investigate and address the problem as soon as possible.

1 Like

Aurum purchasing should now be available normally. Thanks for your patience!

If you’re still having trouble opening this window, we recommend double-checking that the Steam overlay is enabled (if you play through Steam) or temporarily disabling your firewall and antivirus software before restarting the game.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.