Unfun with Connectivity Issues

Ever since I updated Windows 10 today, Secret World Legends won’t connect. It tells me to check my connection and/or firewall. I’ve tried shutting off my firewall and anti-virus, but it doesn’t help. Next I tried resetting my modem/router, and that didn’t help. Then I tried logging in to the modem/router to add the TCP and UDP port ranges listed in this website, but it tells me that they’re already in use by Here I’m at an impasse, as I don’t know what to try next. Any help would be greatly appreciated.

UPDATE: So it seems that is exactly where I want this stuff. All the ports listed on this website are open. I also added local ports 59451, 59854, 56101, at the suggestion of someone online. Still nothing. I can’t log in. Same error. The server is online and everything else regarding the Internet is working, so I have no idea what the issue is.

1 Like

It’s not you, ICANN messed up backend data. Funcom staff are in contact with them about resolving the issue.

There’s a workaround that’s been identified if you’re comfortable enough messing with Windows to change the hosts file.

What is the workaround? How does that work? Installation tips would be good please.

EDIT: This should no longer be necessary for most players.

Use at your own risk. If any of this sounds like Greek to you, better wait for the issue to be resolved by Funcom.

A temporary workaround, courtesy of Nevys on the SWL discord:

Open C:\Windows\system32\drivers\etc\hosts as an administrator and add the following lines to it: um.live.secretworldlegends.com chat.live.secretworldlegends.com

Just remember to remove those lines once the underlying problem has been fixed. It may cause login issues if the server addresses change in the future.


Thanks, I’ll wait for Funcom to fix :smiley:

1 Like

Yes, if this looks complicated waiting for the pros to fix it is the safest option.

1 Like

For the sake of options, I’ll add that there are currently three other IP addresses one could theoretically pick from for um.live.secretworldlegends, so someone has more options than just for this one!


If one of the four doesn’t work, try another!


Your choice, but the fix is trivial to apply.

  1. Start Notepad in Administrator Mode
  2. Open the file named
  3. Paste the two lines at the bottom of the file
  4. Save the file.

When you no longer need the fix, simply delete the two lines

It seems to be working again! I’m glad it wasn’t on my end. Thanks for all who replied!

1 Like