UNNOTED CHANGE/BUG: Game takes 45-85 seconds longer to exit

Game mode: Online official | Online private | Single-player
Type of issue: Performance
Server type: PvP
Region: NA
Mods?: No
Edition: Steam


Bug Description:

The game client takes a long time to close.


Steps to Reproduce:

Play the game normally, as you have every night since May 5, 2021, and now notice the game takes around 50-90 seconds to completely close.

  1. Play game
  2. Exit game
  3. Wait around until Steam shows the client is closed
  4. Scratch your head, mumble some unsavory stuff.

This issue, while it appears benign, can actually cause a few issues with PC power management. If one tries to make his PC sleep before Exiles fully dumps, his PC might restart* at unusual or inconvenient times. This can also cause a partial system hang if hibernation is being used on the client PC.

* Edit originally mis-typed as rastart, which is a fine mashup.

2 Likes

Can confirm the same issue occurring on my machine - shutting down the game takes considerably longer than it used to. I also get a ‘Conan Sandbox is not responding’ error message about one in three shut-downs and have to force close (which generally works out quicker than the ones where it shuts down ‘properly’).

On a possibly related note - I also find the game takes maybe 10-15 seconds longer to load than it used to - but I figured this was just an issue with the new launcher slowing things down (possibly by spending bandwidth/processor on background videos…)

2 Likes

Hello, could you please send us a detailed list of your PC specs?

Core i7-8700K @ 3.70GHz | ASROCK Z370 Pro4
16GB RAM at 3000MHz
EVGA GTX-1060 6GB RAM
RAID-based M.2 SSDs for 1TB C: Drive → CE launches from here
500GB SSD → secondary/cache
1TB 7200 RPM WD Hard drive → backup
Realtek Audio
No WIFI, all hardwired via Ethernet
Identical setup before and after

1 Like

@Barnes are you speaking about the case, when Steam shows the game as running? Or when you click in-game to quit to desktop?
Because (for me at least, but I installed the game on SSD) the former takes a good 15-20 seconds to Steam to switch from ‘running’ status to normal (‘launch’), and the latter takes roughly 5 seconds, when it says ‘disconnecting’ (or something like that) when I only play offline Single player (why is still a thing tho in SP…). Forgot to mention: it is on 2.7 live, and was like this before too.

The simplest way to explain it is CE is not “unloading its resources” the way it used to.

IF you’d like a demo of it, the simplest way is to watch your “Friends” panel in Steam. Regardless of system state, CE now takes much longer to unload than ever before.

In my office, I have several computers, two of which are gaming-quality. While I’m playing CE I can monitor various things on my notebook, for example, where I have a “friend” account on Steam.

In past patches, my exiting CE showed Barnes playing one second, then out the next. Same on my gaming computer, same on the Friend PC. Now when I exit, both Friends panels show my in-game status for 30-45 extra seconds.

IF I were to put my gaming rig to sleep during this interval, it will show my Barnes ID as still playing CE. My gaming rig will also wake up later in the night, during which it closes CE fully and then goes back to sleep.

1 Like

I think it’s a steam issue actually. Been happening for a while now and it does it pretty often with most of my games. I end up having to task manager kill it in the end or it runs forever.

3 Likes

Thanks for that! I haven’t noticed it with other titles, but I’m only playing one other one right now.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.